[solved] Mac address issues new devices

i've added a new device to my wifi, and try to assign a static IP address.
the device is seen in openwrt ( but it assigned a different ip based on what seems a spoofed mac address

|yeelink-light-color1_miio72938090 86:16:F9:6A:B4:9D 6h 9m 44s
YeelightTV 78:11:DC:6A:B4:9D unlimited

so the device (the yeelightTV) has mac address 78:11:DC:6A:B4:9D and static ip *.102, but it gets assigned the dhcp ip of *.179

the last part of the mac seems the same, but the first part (86.16.F9) looks to be spoofed.

also i have other devices that start with the same 86.16.F9 spoofed address

The mac address has to match in order to get assigned the static lease you wish.
I would suggest to use the "spoofed" mac address in order to solve your problem.

1 Like

You can reserve IP addresses by hostname instead of MAC.

Any MAC that has bit 1 of the first byte set (e.g. 86 = 1000 0110) is "locally administered" which generally means that the device assigned it at random.


i added the spoofed address to the statuc leases and now its working

1 Like

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).


1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.