[Solved] Lucy-proto missing

I have openwrt 22.03.2
I have been using wireguard, no problems with it.
I reseted the router, and uploaded an image that worked. But now, I'm getting the error unsupported protocol type, lucy-proto missing.
I have restarted the router (as suggested), and i have the same error. The VPN is not working.

Did you reinstall the wireguard packges?

luci-proto-wireguard and luci-app-wireguard

opkg update
opkg install luci-app-wireguard

Just install luci-app-wireguard with opkg. It installs also luci-proto-wireguard in 22.03.

If you use 23.05, then just luci-proto-wireguard is enough.

1 Like

yes, thanks, it worked. But i don't get it. The image was made with wireguard and all dependencies already installed.

What was the recipe for your image?

I don't understand. I made the backup from system-backup-generate archive.
And I have another question. If I upgrade openwrt (i see 22.03.5 is the latest), will it keep all the settings? Including wireguard.

The backup only stores settings, not additional package installations.
Backup will keep also wireguard settings, but not the wireguard modules.

If you just install a normal sysupgrade image, you will lose the add-on packages (like wireguard stuff) that you have installed.
If you do the upgrade with auc / attended-sysupgrade, it will try to keep also package selections.

1 Like

The Firmware Selector can also be used to make a custom firmware with the desired packages included.


Ok, but if i understand well, the wg settings will be kept (in case of an upgrade), and i'll only have to reinstall luci-app-wireguard. Like i did now. Is this correct?


(or you may compile a personal firmware with those packages included in the image)

1 Like

ok, thanks everyone.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.