[Solved] Luci won't let me specify a port range

I'm trying to create a firewall hole for mosh, which requires opening a range of UDP ports.

I can do this if I simply edit the config file, and specify "option src_dport '60000:60020'", but if I try and use Luci, the text entry box turns red as soon as I type a ':' or a '-', and won't let me save the changes.

Clearly this must be possible using luci -- what am I missing?

Try 60000-60020, instead of colons.

1 Like

I did. As I said, as soon as I type a ':' or a '-', luci reports an error.

What version of OpenWrt are you running?

Luci only shows an error if you haven't finished typing a complete valid string

Would be an error
Would be valid

Oh!! That was my problem. I was so sure that it wasn't accepting the range separator character that I never finished typing the second port number. Probably if I had been configuring 2 digit ports, rather than 5 digit ports, I would have figured it out myself. Oops! Thanks.


1 Like

If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.