[Solved] LuCI translations not working after modifying LuCI files

I have a translation installed but when I save & apply, or reboot it there is no difference. I did remove some pages from the LuCI interface, but I did not think it would affect it because it seems the .po files just translate matching strings, is that right? I tried make package/luci/clean to rebuild LuCI already. I also deleted the po2lmo.o, template_lmo.o and po2lmo files, which were rebuilt during the recompile. Is there anything else I can look into?

Might be silly question, but if youre applying a language translation you might need to delete the cache for changes to apply.

rm /tmp/luci-indexcache

I rebooted and there was no change. /tmp/ is in RAM so I think it gets cleared on a reboot.

Any hints on this? I only removed a few menu items and changed the text of some areas in LuCI. Most of the text changes were within the luci.translate() functions so I think I will have to update the translation files, but shouldn't the items that were unchanged still translate successfully?

Solved it. I had commented out the "design" option and that had caused the language to not be applied.

in system.lua

 o = s:taboption("language", ListValue, "_mediaurlbase", translate("Design"))
 for k, v in pairs(conf.themes) do
 	if k:sub(1, 1) ~= "." then
 		o:value(v, k)

but I did not get the rest of the function.

function o.cfgvalue(...)
	return m.uci:get("luci", "main", "mediaurlbase")

function o.write(self, section, value)
	m.uci:set("luci", "main", "mediaurlbase", value)

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.