[Solved] Luci shows Wireless "disabled" but tooltip "No signal" 19.7.2

On the Wireless Overview, Luci confused me by showing some SSIDs as "disabled", although the Disable button was also shown. Hovering over the 'disabled' indicator, the tooltip showed "No signal".
But the SSID is active, and changes to show the signal strength when a device is associated.

Yes I noticed that too, it was very confusing when first noticed so now I just use a wifi scanner on another device if I have doubts.

I noticed that too, It also shows a little disabled picture if the interface is really disabled

Very confusing when I first noticed.

The icons seem to be correct and consistent with the actual status of the network, as well as the available button.

It's just the text that's incorrect, so probably best to change it to "inactive" or something like that for when it's enabled but not associated, and keep the "disabled" text for when it's, well, disabled (i.e. made unavailable).

1 Like

Not sure what the correct term should be, Maybe Associated or maybe idle

In 19.7.3 the icon shows "--- dBm" and the tooltip shows "No client associated".

Much clearer now, thanks.

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like