[Solved] Luci revision numbers

I just updated luci for 17.01.5 and noticed that the installed version is git-18.201.27126-7bf0367-1 but the version shown in Luci footer (git-18.147.69097-36945b5)
I rebooted after updating but that had no effect.

What did you update exactly and how?

opkg install --force-reinstall luci

Thats just an empty meta package. You need to update luci-base, luci-mod-admin-full, luci-theme-bootstrap etc.

sorry before that i did

opkg list-upgradable | cut -f 1 -d " " | xargs opkg install

but when i saw the version numbe didn't change I tried force reinstall on luci


The version string was found here:
/overlay/upper/usr/lib/lua/luci/version.lua:luciversion = "git-18.147.69097-36945b5"

Reported Bug


After installing the updated version of luci packages the correct luciversion string was in the file

It was necessary to remove cache files for the correct version to be displayed in the browser.

rm /tmp/luci-modulecache/* /tmp/luci-indexcache

AFAIK luci apps delete the /tmp/luci-indexcache file on install/thru uci-defaults.

Maybe you should create a bug on github against luci project to make sure that luci-base runs rm /tmp/luci-modulecache/* in its uci-defaults script?

Bug report raised

The files in /tmp will not survive flash & reboot, so you can only run into this if you update LuCI and do not reboot.

I no longer see the issue after reboot, I'm not sure how/why I observed it the first time I reported the issue.

You are correct. I only observe the issue if I install updated Luci packages without reboot.
Flashing a new firmware image obviously does not cause this issue.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.