[Solved] LuCI, Model "Unknown"


luci shows the following,
Model unknown

But, in dmesg I find,
[ 0.000000] MIPS: machine is Netgear WNDR3700 V3

Any reason why luci can't find this also? I admit, I'm not sure what luci is using for it's input.


ubus call system board which should parse /tmp/sysinfo/board_name

Thanks. Interesting, here is what I find,

root@wap-garage:~# ubus call system board
        "kernel": "4.14.54",
        "hostname": "wap-garage",
        "system": "Broadcom BCM4716",
        "model": "unknown",
        "board_name": "Netgear WNDR3700 V3",
        "release": {
                "distribution": "OpenWrt",
                "version": "18.06-SNAPSHOT",
                "revision": "r7174-cf5a892430",
                "target": "brcm47xx\/mips74k",
                "description": "OpenWrt 18.06-SNAPSHOT r7174-cf5a892430"


root@wap-garage:~# cat /tmp/sysinfo/board_name
Netgear WNDR3700 V3

So it seems the info is there, luci is just not using it for some reason? It does seem above like model and board_name are a bit mixed up / swapped?

Thanks again.

The Asus WL-500W (brcm47xx as well) is affected by the same issue, which I reported as FS#1576.
I tracked down the offending commit, but did not look any further.

Thanks! I updated the ticket, just so they know it does affect other devices.

Much appreciated!

I tested the latest OpenWrt 18.06 snapshot (r7186-f4798d3) using a Linksys WRT54GS, and I can report that the model display has been restored to Linksys WRT54G/GS/GL. Thank you @jow!

Yep, running r7191 now, and it works. Thanks!

Can you tell me...what version of the WRT54GS do you have???
I didn't have success upgrading to 18.06 previously:

EDIT: I just installed OpenWrt 18.06-SNAPSHOT, r7186-f4798d3 - and it worked too!