[Solved] Low speeds when NATing with TP-Link Archer C7 v5

I just installed Open WRT everything went alright, but I'm not able to achieve speeds higher than 30 Mbps (Got 160 Mbps at home), started with version 18.06.1, reading some posts then I installed the ath79 version, and enabled HW NAT, I still have the same issue.

I don't know if it is because my ISP is already doing NAT on their device, but I didn't have that issue with my previous router.

Gotta mention that if I disable DHCP, and plug this router as a switch + access point, it works with full speed.

Any idea or pointer on what to look for would be really appreciated.

Without SQM, without offload, you should be able to comfortably get 300 Mbps out of an Archer C7, unless they strangled it horribly since the v2.

Are you running anything other than what came with the OpenWrt image?

I tested it as soon as I installed it with no add-ons or extra stuff installed and had the same issue.

Edit: Turns out the computer I was using to test had some issues negotiating a GE connection. It is all solved now.


It helps others to edit the post thread to start with [Solved] or the like, as well as using the "solution" checkbox (which will reference that post in the lead post).


1 Like

Done, thanks.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.