[SOLVED] Losing Configuration After RP-WD03/OpenWrt 18.06 Reset

I installed OpenWRT 18.06 on a RavPower RP-WD03 and successfully configured WiFi and extroot on a 1GB SD card. Everything seemed fine after multiple reboots/power-cycling. I was trying to trap power button presses to see if I could graceful unmount the SD card before the RP-WD03 shutdown but had no success. The RP-WD03 has a reset button, which I thought only worked during boot. Pressing the reset button while OpenWRT was running was recorded in the log but forced a jffs2reset.

Fri Aug 17 11:12:06 2018 daemon.info jffs2reset: /dev/mtdblock6 is not mounted
Fri Aug 17 11:12:06 2018 user.notice root: the button was reset and the action was released
Fri Aug 17 11:12:06 2018 daemon.info jffs2reset: /dev/mtdblock6 will be erased on next mount
Fri Aug 17 11:12:06 2018 daemon.info procd: - shutdown -

I reconnected via Ethernet. The root password I had set earlier was still valid, but everything else had to be reconfigured. I also had no access to the SD card. I rebooted and lost all the configuration changes. There are posts about the overlay not being written to flash, but the RP-WD03 has 8MB of flash and it looks like overlay (mtdblock6) has sufficient space.

root@OpenWrt:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                 2560      2560         0 100% /rom
tmpfs                    13980       396     13584   3% /tmp
tmpfs                    13980        48     13932   0% /tmp/root
tmpfs                      512         0       512   0% /dev
/dev/mtdblock6            4080      1868      2212  46% /overlay
overlayfs:/overlay        4080      1868      2212  46% /

The other odd thing is that I had previously had to install block-mount, kmod-usb-storage, and kmod-fs-ext4 to gain access to the SD card. When I tried to re-install them, OpenWRT indicated that they were already installed. opkg remove/install of the three packages 'fixed' that problem - I was even able to manually mount the SD card on /overlay. However, a power-cycle wiped out all the changes again. I did see "mount_root: jffs2 not ready yet, using temporary tmpfs overlay" and later "overlayfs: upper fs does not support tmpfile." in dmesg but am not sure if they were there before.

I have tried a soft and hard factory reset but do not think anything is happening:

root@OpenWrt:/# umount /overlay
root@OpenWrt:/etc/config# jffs2reset && reboot
This will erase all settings and remove any installed packages. Are you sure? [N/y]
/dev/mtdblock6 is not mounted
/dev/mtdblock6 will be erased on next mount

My guess is that the mtdblock6 overlay partition was somehow corrupted by the reset. Is my next step a firmware update to reflash OpenWRT 18.06 on the RP-WD03? I assume I can do that through LuCi (I originally upgraded the RP-WD03 stock firmware to OpenWRT via tftp).

Thanks, Norbert

Re-flashing the 18.06 OpenWRT firmware resolved the problem - configuration changes are once again saved. I am still unclear what triggered the problem.

Regards, Norbert