[Solved] Linksys WRT32x General Help

Hi all,

Just bought myself a new WRT32x to replace an aging Netgear WNDR3800, which has served me well for a long time running OpenWRT.

I'd like to put LEDE on the WRT32x and had ordered myself a USB to Serial adapter and everything understanding that i'd need to flash over serial. The USB turned up today, but it looks as though the work has been done to make the firmware flashable through the stock GUI. Bonus!

I downloaded and flashed which went without a problem. Connected with SSH and wanted to get LUCI installed but i'm getting the errors below:

root@OpenWrt:/tmp/luci-offline-packages# opkg install /tmp/luci-offline-packages/*.ipk force
Package libuci-lua version 2018-01-01-141b64ef-1 has no valid architecture, ignoring.
Package rpcd version 2018-05-13-82062195-1 has no valid architecture, ignoring.
Package luci-lib-ip version git-18.118.20919-cfba791-1 has no valid architecture, ignoring.
Package libubus-lua version 2017-02-18-34c6e818-1 has no valid architecture, ignoring.
Package liblua version 5.1.5-1 has no valid architecture, ignoring.
Package lua version 5.1.5-1 has no valid architecture, ignoring.
Package luci-mod-admin-full version git-18.118.20919-cfba791-1 has no valid architecture, ignoring.
Package luci-base version git-18.118.20919-cfba791-1 has no valid architecture, ignoring.
Package libubus version 2017-02-18-34c6e818-1 has no valid architecture, ignoring.
Segmentation fault

Does anyone have any idea how to get these packages installed? They were downloaded from https://downloads.openwrt.org/snapshots/packages/arm_cortex-a9/

While i'm happy to configure from scratch, installing the packages i need and setting everything up, i'd rather use an image created by someone else such as @davidc502. With 3 kids, one of which is 11 days old today, i just know i wont find enough time anytime soon.

David, Sorry to tag you... I understand you're the man when it comes to builds for the Linksys AC range so i wanted to ask how soon you think you can have an image for Venom? I saw on your page you've stated they're coming soon. How soon amigo?

Any help or advice will be greatly appreciated. Meanwhile i'll continue googling!



Any of the last 2 or 3 images off the link found on my avatar should have the requisite commit for the venom. Not sure why the error on the packages for the snapshot target.

I'm thinking I'm going to do a new build this weekend that will include Venom.

Understand about the kids and not to forget the "better half" lol... It's a full time job in itself. < Cheers

Thanks David... Legend!

Yeah, the better half is harder work than the kids, haha! I look forward to getting my hands on that image!

Anomeone, thanks for the nudge in the right direction, i now have luci, oooshh!

Now on to wifi, dnscrypt, adblock, openvpn and the rest! I'm sure i'll be back for more nudges!

I should start off by asking the obvious question of if you tried installing just 1 package :slight_smile:

Also, any particular reason why the packages were sent to temp, and then installed instead of over the web?

The problem with installing the original packages was that i hadn't downloaded the vfpv3 versions. Not exactly sure what the difference is but i noticed that all of the packages on anomeome's GDrive had this suffix. I have now downloaded multiple packages with that suffix and they've all installed fine.

I don't currently have the new router connected to the web, i have it plugged in to my laptop while i get it configured. I know there's probably a very simple way of hooking it up to the current router and allowing the new router to connect to the web through it, but for now i'm content downloading each package manually and using WinSCP to copy them over, then running the install command through SSH.

It would be a lot easier if i could install the packages through luci. If i connect the new router to the current router using LAN ports on both would that allow me to download the packages directly through luci?

Also, i have an error whereby none of the wireless radios work. They're all showing "disabled or not associated". Haven't spent any time looking in to it yet but if you have any ideas i'd be grateful.

Honestly this will probably all be for nothing once you UL your image, but i could do with a refresher anyway and who doesn't like tinkering with new gadge!

Ok, so i was missing libiwinfo packages, wifi was working, but no detail was being displayed in luci.

All sorted now.

If your question is solved, please consider marking this topic as [Solved].

Hi tmomas,

That particular query was solved but on the whole i still have need of some assistance.

I'm almost done setting the router up however for some reason radio0 and radio2 wont stay up. I'm wondering whether something i have changed has caused this. radio0 seemed ok initially when, by default, it was set to AC only, Auto channel and 20Mhz width. Country code was DE, i think.

I attempted to set the width to 160Mhz and changed the country code to 00 which i think is when i began having this problem. I've tried all sorts of changes, setting the country code to GB and DE, setting the width to 80, 40 and 20Mhz, and choosing a specific channel, but nothing seems to help. The interface comes up for a second or 2 then drops.

I also tried playing around with the settings on radio2 which i have read is a radar scanning radio that isn't used, but i was having the same problem, as though these two radios are connected, possibly using the same driver, IDK. Decided to disable radio2 and focus on one problem at a time.

Anyone had a similar experience? I know the firmware is pretty new so i might be alone on this at the moment.



Ok, just set everything back to default and radio0 stayed up. So i kept upping the channel width and it seems to be the 160Mhz setting that breaks it.

I'll stick with 80Mhz for now and see how it goes. Hopefully this will be fixed with updates.

I'll mark this as solved and open a new topic if i need any further assistance.

Thanks everyone!

Anyone know where i should report potential bugs?

I'll do some more testing and submit my findings seen as it looks like i'm one of the first to try this firmware.


Edit: Found it... nevermind

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.