[Solved] Linksys WRT3200ACM accidentally reverted to stock firmware?

I was tweaking my DHCP config file today, and I probably made a typo. I've done this before, and when the router (Linksys WRT3200ACM running OpenWrt 19.07.7) next reboots, various parts (primarily dnsmasq, I imagine) don't work, but I can usually log in via SSH and fix it with no problem.

Today however, I was not able to reconnect to the router. I tried powering off and on a few times, and then I noticed the router's address had changed to When I went there, I was greeted by the stock Linksys web interface login page. Somehow the router was now running the stock firmware, without me doing anything more than power cycling a few times (and possibly crashing dnsmasq with my bad typing).

Has anyone else experienced this before? I had thought that when I flashed the router to OpenWrt, the old firmware was gone from the machine. Does Linksys have some kind of backup anti-bricking system that re-installs the original firmware automatically? I'm so curious!

This is a dual-firmware system... power cycling multiple times without allowing a complete successful boot to happen will switch to the other partition.

1 Like

Correct per @psherman,

Using the power switch,

  • power off ~5sec
  • power on and wait for right side Eth ports to come up and then power down
  • repeat above step 3 times
  • let it boot. It should come back up to your OpenWrt partition.

Pay attention to the led sequences. Don't let it get too far into the boot sequence. A couple attempts might be needed to get the timings right.

Of course! Thank you so much for explaining it to me.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.