(Solved) Linksys WRT1900ACv1 5ghz initially not working


Can someone help me troubleshoot why my WRT1900ACv1 5ghz is not woriking on 18.06.2.

It has never worked since i switched to OpenWrt from stock Linksys firmware.

You're going to have to provide more specific info than "not working".

it looks like this

It's not "not working". I imagine you have left the channel at Auto and there isn't any connected clients, so it will look like that.

Did you try connecting a device and it failed?

I have found the fix.

I added option noscan '1' to wireless config.

It is already working now.

1 Like

If your case is solved, please mark the topics as such.

Also if you believe that you left the radio on long enough and it didn't happen to choose a channel, you may like to open a ticket here https://bugs.openwrt.org/

Did you, for the sake of finding out, try to set the channel and see if it will work without option noscan '1'.

Surprinsingly, if i remove the noscan option, the wireless AC still works. it seems that the noscan was like an option to jumpstart the 5ghz.

And also adding noscan in the wireless config enables the Force 40MHz mode in the advanced settings of wireless config. And unchecking the Force 40Mhz mode removes the noscan line in wireless config.

I dont know if that is a bug or not.

Force 40MHz mode and noscan options are essentially the same thing. Normally even when the use chooses bandwidthof 40 MHz, the router will not scan for neiughbour WiFi networks to check for potential frequency overlap and accordingly narrow the channel width to 20 MHz if there is an overlap. noscanmeans that the router will not do the scan and therefore force the 40 MHz channel width. (I don't know what happens for 80 MHz channels though.

It's worth adding that some channels are redistrict in some countries.

im using channel 40 at 40mhz.

my country has the same restrictions with US/Singapore.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.