[Solved] Linksys WRT 3200 ACM, trying to sysupgrade .bin to 18.06.3 (New FW Version) doesnt work

Hello Community,

I check regulary if new Firmware is released, so today I saw 18.06.3 is released, and dled the .bin for my LinksyWRT 3200 ACM, then went to System Menu of OpenWRT Webinterface -> BackUp Flash Firmware Menu, and choosed -> Flash new firmware image ... then choosed KEEP SETTINGS, and choosed the openwrt-mvebu-cortexa9-linksys-wrt3200acm-squashfs-sysupgrade file, i dled.

OK, reboot, but it shows still in Luci Webinterface-> Menu -> OVERVIEW version -> OpenWrt 18.06.2 r7676-cddd7b4c77 / LuCI openwrt-18.06 branch (git-19.170.32094-4d6d8bc)

What I am doing wrong? why it doesnt show OpenWrt 18.06.3 ??

Someone has a hint? Thank you for any help or hint!

With kind regards TommyMac

Peace :blush:

This device has two boot partitions. When you flash it, it flashes the other partition. So to have both partitions flashed, you have to flash a second time after booting from the partition you just flashed.

Though, I recommend that you try 18.06.03 first before you flash the other partition.


Thanks mhegab for reply,
I thought It will upgrade the current partition Im booting from, so for to upgrade, I have to boot into the other partition, make the upgrade there, for the partition Im using now get upgraded, and then switch back...to the partition Im using now, correct?

Thanks a bunch!

Yes it's correct.

But to make good use of the dual boot thing, while you are on the other partition (which you just updated), give it a try first and make sure all is working well with the new release before you update the first partition.

1 Like

If you boot to partition A and issue the sysupgrade routine, partition B is upgraded. After flashing, you automatically boot up on partition B.

Just to take this a step further, the next time you sysupgrade from partition B, partition A is upgraded and will boot to partition A. Round robin of sorts.


Thanks a bunch for explaining, mhegab and davidc502 ...this really helped, now I know, for the future, what to do in case of doing a upgrade! I only hope, I find the pw...lol, I had setup for the other partition 1 (a), as I used partition 2 (b) since many many month :innocent:

in worst case, I must reset partition 1 (a) to get access... lol

Have a good new week, and again, Thank you both

1 Like

When "keep settings" is chosen, those setting are sent over to the other partition as well.



1 Like

Wonderfull News davidc502, Thank you! I love OpenWRT, very very happy with it!
So as it passed the setting to the other partition, it then should have same PW...Wonderfull :smiley:

1 Like

Great; good luck!

FYI, when you want to mention people, you could add "@" before their username (like I did here); this sends them a notification.

1 Like

Fwiw I upgraded to 18.06.3 on my wrt1200 today and it seems to be working fine, so hopefully the other mvebu devices are working ok too.

1 Like

@MooMan If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

1 Like

Hi can you let us know how you get on flashing pleas. I am having a problem flashing to, but am not sure that it is the same one. thanks.

1 Like

@tmomas sadly, I have massive Problems, DNSCRYPT doesnt work anymore for me...so its not solved yet....Im thinking go back previous version... but will now retry, if I get 18.06.3 to work....if not, go back prevoius version...

18.06.3 hasn’t officially been released, as far as I know. Many of the repos are still being built or rebuilt.

1 Like

I only can say, dont do it... was a mistake...I did it ...better wait, I had to go back 18.06.2 :upside_down_face:

@tmomas ..seems Im a idiot, cant see behind pencil a OPTION to mark it for SOLVED :grimacing: ..where is it, on TOP? where my first Text is? I see Pencil there, but only Time right beside it when I postet it.... when I press the Pencil, it opens only a HISTORY Window....

Did that now for you, to shorten the process :slight_smile:

1 Like

I then see only the pict above.... :frowning:

OK, now I see a SOLVEDin front of it! Sorry :frowning: