[Solved] Linksys E5600 reboots to stock. Need a better solution

I have the E5600 running the latest RC1 for 22.x branch. It has worked well over the last year. Turns out though if the device experiences a power loss, it will reboot into the alt_firmware which is usually stock firmware. You can reboot it into openwrt again by pressing the wps button twice but I am not sure why this behaviour exists. Personally I would love to convert the entire flash layout to UBI like the RT3200/E8450 as this seems like a really good cheap alternative to it but I am pretty sure ill need mentoring on how to go about it. Either way currently I want to know what is a better solution to fix this issue for this particular device.

1 Like

On other dual-boot devices, the alternate partition is activated only when there are three failed boots on a row, and that is quite unlikely.

Also, each time you install OpenWrt, it goes to the other partition. So, installing and configuring it twice should make things more manageable.

Unfortunately the router fails every time to boot into openwrt. It will reboot 3 times, fail all 3 times and then boot into the alt firmware which happens to be th stock firmware.

Well, this is the big issue here...

If I press the wps button then it will boot into openwrt, which is I think a method to boot from the other partition.

I do not know about your device, but that looks like a serious bug to me. Perhaps you should report it.

Just to comment: I've the same issue with my device. I Will keep trying some Solution n share it.

Hello everyone,
Last weekend I was trying to solve the reboot Alt-firmware bug and I found interesting that after flash the version.

FW E5600 version 1.0.1.130

Firmware version: 1.0.1.130
Release date: Aug 5, 2020

Public Release Note

  • Fixed duration crash
  • Fixed when rootAP change Wi-Fi channel, DUT will can't reconnect and client can't connect
  • Fixed DUT does not update time when it boots up for NTP
  • Fixed automatic Firmware Upgrade doesn't work properly in DHCP mode
  • Fixed time Zone is not set to local time zone after completing setup.
  • Fixed parental Controls page is not supported on iOS.
  • Enable auto firmware upgrade as default
  • Integrated general bug fixes.

I was able to boot OpenWrt on the primary partition without problem, I will keep rebooting and testing next days to confirm...!

Best Regards

1 Like

Hi.
I manage a EA7300 which is a close device. I also had an issue for installing OpenWrt, please browse this page for info.

After flashing Linksys, you booted from alt partition. Than flashing Openwrt will install it on primary partition, and it boots. That is what I succeeded to do on a EA7300.
But did you reboot your device several times ? More than 3 ? That is when the bootloader count issue may appear.

EDIT : I just read the E5600 page, it describes the same flash process, but no boot count issue.

So as it turns out I was able to eventually get OpenWRT running even on the latest 1.1.0.26 firmware. I just had to reset it to factory and keep it off for some time (I am assuming to let it power cycle correctly). I was also able to flash the factory of 21 stable.

However interesting to note that I first did flash that firmware you mentioned then flashed openwrt then went to stock again on latest and now its working.

The best thing for this device still is to switch to UBI layout. But I dont have the tools right now for it (to get a flash dump). I do think though it will be a fun project for me to learn though.

Update: I also noticed this is a binned chip (at least in mine) that doesnt run at 880MHz. It shows 583.68MHz.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.