[solved]: Lede X86, how can I activate wifi interface?

I am new to LEDE X86. Why is wifi not active by default? It should be in this day and age. So how can I activate it with GUI if possible?

I'm using Lede 17.01.2 X86 version on a Toshiba laptop with Intel wifi and netcardd.


Having wifi come up on the first boot is a potential security issue. A neighbor could connect and hijack your router.

Since an x86 system could have any wifi hardware (or none), no wifi drivers are included by default. You need to identify the chips used in your wifi card and install the kmods for it.

So how to turn on wifi? I have read messages and googled for 3 weeks, but I still can't turn on the wifi.

The Opkg Update command gives me the " wget returned 4" error. So how can I get past that? My test system is behind an ISP supplied dsl modem router.

I can see the reason for wifi being off but not including some of the basic drivers is not user friendly at all. Not everyone is a Linux wizard. For the X86 install, HD space should not be a problem.

If I ever get this working, I'm gonna write a Dummy's Guide to Lede-WRT.

It's helpful to detail exactly which version\release of LEDE you are using or if you "rolled" your own.

The release versions of LEDE comes with Luci, and you should be easily able to easily enable it through the Network => Wireless menu.

If you are using a dev build you can also install Luci to make it easy on yourself. Be aware that if you loaded a dev version 3 weeks ago, you may have issues trying to load the current versions of the dev packages as kernel and other things may change. you may have "version mismatch" issues. It's always best to either load all the packages at the time you install the dev build or to download the package repository for local use. You can still run things from a command prompt if you want the pain.

When you;re not routing through LEDE-- that is it is a device on your LAN with a static IP-- you need to configure the LAN network interface's gateway and DNS to the IP of your main router. Then LEDE can access the Internet and download packages.

@mk24, Thanks for the info. This is what I did to get OPKG updates.

  1. connect to the home router (ip: on another PC to copy down the DNS ip addresses
  2. connected another pc by ethernet cable to the Lede X86 system to login. (connection through the home lan router is not possbile)
  3. log into Luci web interface and selected network - interfaces, then selected the "edit" in the active lan interface.
  4. go down to the gateway field and enter the ip address of my home router, which is Then entered the DNS server ip addresses into the DNS field.
  5. click save and apply.
  6. unplug the ethernet cable from my PC end and plug it into the router.
  7. on Lede system, enter command "opkg update"


If I unplug the net cable from the router end and reconnect it to my PC, after login to Luci I can see all the available packages under System - Software - Available packages.

Question: how can I have Lede X86 hooked up to the home router and still access it from my PC without the net cable swapping so I can install the packages?

And is there a way to activate the wifi interface in Luci?

And is there a way to activate the wifi interface in Luci?

On the LuCI toolbar, select Network, then Wireless.

When you are using a LEDE box as a device on an existing LAN (as you are), turn off LEDE's DHCP server. Having two DHCP servers active will cause problems in the network.

On the LAN page scroll down and check the "disable DHCP on this interface" box, and save. Click the IPv6 tab and set Router Advertisement and DHCPv6 to "disabled". Save and apply.

Make sure your LEDE box's IP address (default of is not used by any other device in the network. Once that is the case, and DHCP server is turned off, you can leave the LEDE box connected to your network and everything should work. You can access it by its IP.

To activate the wifi interface in LUCI, use the Software page to install the drivers needed by your hardware, then reboot. You should then have a Wireless page under Network.

Most x86 hardware has a VGA or HDMI output and USB ports. The video should already be active as a text terminal. If you install kmod-usb-hid then you can connect a USB keyboard and have local control via a shell. This is useful to have set up in case networking gets misconfigured.

@jwoods, as far as I can see in X86 install, there is no wifi option as none of the wifi drivers are installed by default.

@mk24, Thanks, Got it working. My LEDE box is an old Toshiba laptop so keyboard and video are all working.

This is what I did:

log into Lede box, under Network - Interfaces, select "edit" from the active lan card and tick disable DHCP server, then move to the IPv6 tab and select disable for Router Advertisement and DHCPv6.

Now my LEDE box is part of the home lan and I can configure it with Luci from another PC.

Because I'm using an Intel wifi card so I install all the Intel Kmod wifi packages:
kmod-ipw2100 4.4.71+2017-01-31-2
kmod-ipw2200 4.4.71+2017-01-31-2
kmod-iwl-legacy 4.4.71+2017-01-31-2
kmod-iwl3945 4.4.71+2017-01-31-2
kmod-iwl4965 4.4.71+2017-01-31-2
kmod-iwlwifi 4.4.71+2017-01-31-2

After reboot, I still don't have wifi interface in Network - Interfaces. What else is needed?

Answer to my own Question:

I installed all the Atheros driver packages, I now can see the wifi interface under Network. Don't know why but it's working now.

At some point, you might mark your topic as solved.

Now that I have the wifi interface up, how can I do MAC Spoofing (changing the MAC address) on the wifi interface?

@jwoods, Thanks for the reminder. Once I transfer the setup to a desktop and have everything working, I will mark it solved.

Add an option macaddr to the wifi-iface section of the /etc/config/wireless file.

I haven't try it yet, but I think this link shows all the packages that is needed for the wifi interface... someone correct me if this is wrong..


That is far from being a complete list.

The packages common to any wifi support are:

Then you will need the kmods for your particular wifi chipset.

1 Like

Do you have $30 to spare? If so, I suggest you get a new or used Openwrt compatible router and flash Openwrt rom to it. You will have all the benefit of OpenWrt without the headaches of setting up X86 OpenWrt.


Make sure you have the right version of the router as manufacturers often change chipsets. Athero/Qualcomm chips are your best choices.

With OpenWrt, I now have free internet for my home and office.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.