[solved] LEDE on Ubiquiti UNIFI AP LR

Hi all!
I'm trying to install LEDE 17.01.0 on ubiquiti UNIFI AP LR.
I get the following error:

Header MAGIC 'OPEN'
Current: BZ.ar7240.v3.2.6.2799.140930.1155
New ver: BZ.ar934x.v6.0.0-OpenWrt-r3636-9e740fa
Invalid version 'BZ.ar934x.v6.0.0-OpenWrt-r3636-9e740fa'

This device seems supported:
https://lede-project.org/toh/views/toh_fwdownload?dataflt[Brand*~]=ubiquiti&dataflt[Model*~]=ap

I'm try with the following lede image:
https://downloads.lede-project.org/releases/17.01.0/targets/ar71xx/generic/lede-17.01.0-r3205-59508e3-ar71xx-generic-ubnt-unifi-squashfs-factory.bin

Someone can help me?

Many thanks

I finally solved my problem.

I'm able to flash this kind of device only with this version of openwrt:
https://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/openwrt-ar71xx-generic-ubnt-unifi-outdoor-squashfs-factory.bin

Then I flash my device with latest lede version for ubiquiti unifi.

Thanks

1 Like

Hi @cappe87 , i ran into your post because i have similar issue.

Please see my post here
Can you tell me how did you flash https://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/openwrt-ar71xx-generic-ubnt-unifi-outdoor-squashfs-factory.bin ?
Did you flash with syswrapper ontop of original Ubiquiti firmware? or did you use tftp?
Please describe the process because im really stuck with this and need your help.

Also is the UAP-LR that you have v2 in the original Ubiquiti firmware settings?

I appreciate your help!

Hi,
I try guide you step by step.

  1. ssh to unifi user:ubnt pass:ubnt
  2. cd /tmp
  3. wget https://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/openwrt-ar71xx-generic-ubnt-unifi-outdoor-squashfs-factory.bin
  4. fwupdate.real -m openwrt-ar71xx-generic-ubnt-unifi-outdoor-squashfs-factory.bin -d

Now I have ubiquiti unifi with old openwrt version.
Flash with lede
1.connect to openwrt
2.sysupgrade -n -v myledefirmware.bin

Hope this helps

Actually this guy didn't mention the Firmware version of the Unify AP LR.

If his firmware was 3.4.* or less than this method is correct and I believe that he was using old Unifi AP LR not V2.
I am pretty sure that this method described above will not work with Unifi AP LR v2.

If someone know how to flash new version of UAP LR or UAP AC LR, and can describe the method, it will be really really useful. I a, ready to pay money to this person!

Cheers,

Ruslan

I know I had to downgrade my Unifi firmware PRIOR to being able to install any open router OS.

Check this issue, it has a few links including to the older firmware: https://github.com/openwrt/openwrt/issues/423

I have Unifi AP Outdoor and I can confirm success with downgrade ubiquiti's firmware from 3.9.something to 3.3.20. I did it with Ubnt's Controller v5.6.29 on Debian 9 for uploading both images (I renamed lede-17.01.4-ar71xx-generic-ubnt-unifi-outdoor-squashfs-factory.bin to BZ.ar7240.v3.3.20.4019.160401.1459.bin althoug not sure if necessary).

UAP LR and different from UAP Outdoor.
Also the issue appear only in UAP LR v2

Sorry, I haven't checked that. Should I post my info somewhere else?