[SOLVED] LAN1 and WAN leds always on on tl-wr740n-v4

While trying the ath79 port for this tiny router i found that LAN1 and WAN leds stay on without any cables attached to it. After commenting out all the leds section in the file "target/linux/ath79/dts/ar9331_tplink_tl-wr741nd-v4.dtsi" and recompiling i still get the same error.
Could anyone please give me an hint where to look further as i cant resolve this issue?
Thank you!

you don't need to recompile the image, the leds are triggered by /etc/board.d/01_leds script
but anyhow, you could try find the right values, maybe is a typo in the script

Thank you. Didn't know.
I'll update you on this.

Comparing the /etc/board.d/01_leds script from ar71xx and ath79 port the values seems to be the same. The only difference has to do with the device associated with the WAN interface. On ar71xx it is "eth1" and on ath79 "eth0".
Just to let you know, turned off all leds on luci and rebooted and those two leds are always on. If a cable is connected on those ports the corresponding leds blink.
It seems like they are on default on state.
Thank you.

I don't remember right now, but you can echo a value in /sys/class/led or something like that, to try to turn them on/off
and there is this commit that removes the default off, maybe if you re-add the default..

If i execute "echo 0 > /sys/devices/platform/gpio-leds/leds/tp-link:green:lan1/brightness" nothing happens. But but if i execute "echo 1 > /sys/devices/platform/gpio-leds/leds/tp-link:green:lan2/brightness" the led corresponding to port 2 becomes on and if "echo 0 > /sys/devices/platform/gpio-leds/leds/tp-link:green:lan2/brightness" it becomes off.
Maybe you're right on the first post and from the ar71xx port to the ath79 port there was a change on the Switch Port Mask.
I'll try this path and let you know my findings.
Thank you.

Hello again.
I tried this commit https://github.com/openwrt/openwrt/pull/1700 and now it's working perfectly!
Thank you for all your help.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.