[Solved] LAN ports work in OpenWrt, but not in OEM firmware - Linksys WRT1900AC

Hi everyone,

I put OpenWRT on our Linksys WRT1900AC to try out, and had some issues with the wifi.
According to what I found in the forums, this can be expected because of the open driver, so I rebooted back to the OEM firmware (yay for dual boot).

However, back in the original firmware, the ethernet ports no longer seem to work.
WiFi and internet are functioning, and the port activity lights are on+ blinking, but no machine plugged directly into the router is getting an IP address.

I booted back into OpenWRT, and the ports started working again.
I installed another instance of OpenWRT over the OEM partition and that worked too.
Flashed OEM onto primary partition, still no functioning LAN ports.
Did a factory reset, still no joy.
Booted back to OpenWRT, and they work again.

It seems that something OpenWRT set is preventing the OEM firmware from managing the lan ports.
I tried turning the VLAN off under switch settings in openwrt, but that didn't seem to do anything to the OEM side. I'm a bit surprised that there would be any shared configuration between the two firmwares, let alone the two partitions.
So I'm a bit at a loss at what else to try.

Google turned up this thread on the linksys forum, but no resolution there either:

Any suggestions?


maybe try swconfig dev switch0 reset on knocking things down; i.e. after you have killed VLANs and are ready to go to OEM.

Looks like that did the trick!

I would have expected the switch to be reset as part of the power-cycle, and/or firmware change.
At the very least, by the factory reset.

Does this mean there is some nvram somewhere that isn't normally touched?

Thanks again!
Now I can keep playing with OpenWRT without too much worry.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

The MV88E6172 has eeprom and iirc the OEM FW for the mamba fails to reset before doing its own configuration, so setting information is retained.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.