[Solved] LAN no Internet Access

I've got a RPi 3, and I'm having a bit of a hiccup with connecting LAN to the internet.

I have 3 interfaces, eth0, the built in adapter. eth1 and eth2, both USB Lan adapters. They're properly connected and identified.

When I open up the web config panel, it shows the IPV4 upstream as the eth0 adapter. Does this mean that OpenWRT is attempting to send packets through eth0? I want eth1 to be the WAN adapter, and eth2 to be the LAN adapter.

I've configured networks accordingly, but routing is still not working. eth1 is DHCP, and eth2 is static. eth0 is also static, but shouldn't have any traffic through it (it's purely a management interface).

What can I do to fix it?

Managed to set the WAN interface to show properly by editing the board.d files.
Still not routing traffic properly.

Can you post your /etc/config/network?

You could have just edited it in the OpenWrt config.

Did you setup the firewall properly?

Please post your /etc/config/firewall also.

1 Like





I very likely didn't set the firewall properly.

You didn't. It's missing A LOT!


  • You haven't declared any firewall zones!
  • There's no rule to permit LAN traffic to go to WAN
  • Masquerade isn't enabled on WAN, as there's no rules for this zone, either
config zone                            
        option name 'lan'                           
        option input 'ACCEPT'                              
        option output 'ACCEPT'                 
        option network 'lan'                                         
        option forward 'DROP'    

config zone                                     
        option name 'wan'                                                    
        option output 'ACCEPT'                
        option forward 'DROP'                           
        option mtu_fix '1'                          
        option masq '1'                                                         
        option input 'DROP'                                  
        option network 'wan'

config forwarding                              
        option dest 'wan'                                            
        option src 'lan'   

Are you using the web GUI?

1 Like

I wasn't previously, mainly using UCI.

I was experimenting last night and didn't get it to work, seems like I missed the masquerading on WAN.

Thank you so much!

1 Like

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.