[solved] LAN (cable) connections not working as expected

Hey guys,

I'm new to OpenWRT and have just set it up on my Asus RT-AC51U. It seems like physical ethernet cable connections are not working/not showing up in OpenWRT.

OpenWRT was installed on my router which has a WAN connection (to the internet) and a single LAN connection to an unmanaged switch. This switch has several devices connected to it (Raspi, server, TV, etc.). These devices are unable to connect to the internet, while WLAN devices are able. I am however able to connect to these devices (through ssh at least) using their old static IP address. They are not showing up in the list of DHCP clients either.

What's going on here? Why are ethernet ports treated so differently here? (VLANs are disabled by the way)

Let me know if there's any config I can post to help.

Thanks!

EDIT: Solved it thanks to the replies! Turns out the devices were all manually configured to use the old gateway IP, and they were coincidentally all devices that used physical cables so I was looking in the wrong direction. Thanks for the help!

are they on the same IP subnet with the router? Can you ping the router?

But should they? Do you have DHCP configured on those devices/interfaces? I guess no, because they are "using their old static IP address"
Are those static IPs on the same IP subnet with the router LAN port?

It looks like you can access the router via Wi-Fi connection. Please show any symptom of OpenWrt misbehavior.

My guess is that the wired devices have not (yet) requested new dhcp leases because their physical wired connections did not go down when you changed the router (because of the switch). Try one or more of these things and see if it fixes the issue (I.e hosts renew their dhcp leases)

  • reboot the hosts connected by Ethernet
  • unplug and replug the Ethernet cables to the hosts
  • power cycle the switch
  • wait 12-24 hours (or longer) for the existing leases to reach at least 50% of their original length - there should be a request to renew when the lease reaches half its length, again at certain intervals, and finally again when it expires.

Are the static IPs of the wired devices within the OpenWrt LAN subnet? If not you need to reconfigure one side or the other. Also if you're using static IPs the gateway must be set to the main router, if it is not the same as your old router was. Usually DNS is also set to the main router.

The DHCP lease table will only show devices that use DHCP. You can examine the ARP table to possibly find others. In general I prefer static / reserved DHCP leasing instead of setting endpoints to static IPs. This way you can place servers at "known" addresses (and also DNS capability), still everything is under control of the router.

1 Like