[Solved] Lamobo R1 - Connect all Ethernet ports and WLAN to a network

I would like to operate the Lamobo R1 behind a Fritz!Box to have more network ports available. All Ethernet ports and the Wi-Fi should be connected to a network. The Fritz!Box to continue as a DHCP server and firewall. Lamobo R1 will get mapped to its IP from the Fritz!Box. All their IP from the Fritz!Box to also get on the connected Lamobo R1 devices (both Ethernet and Wi-Fi). Also all devices on the network to communicate fully.
How do I configure LEDE? Can I turn off the VLAN? How do I get that all five Ethernet connections, the CPU and Wi-Fi are connected.

  • Give LAN the Gateway DNS IP of the Fritzbox
  • Remove the WAN port from VLAN 2 and add it to LAN
  • WiFi should already be connected to LAN

You now have a managed 5-port switch.

Hope this helps.

First I changed the WAN port on VLAN 1 from off to untagged. After that I deleted VLAN 2. Is this correct or does the VLAN 2 have to remain?

LEDE1

The result looks like this.

LEDE2

Now I edit the settings of the LAN port.

LEDE3

What changes should be made here?

LEDE5
LEDE6

Yes, that works too:

  • I went to Network > Switch and changed WAN port on VLAN 2 to off
  • Then, I added WAN port as untagged to VLAN1 (LAN).
  • I hit Save and Apply

At this point, there's no access to VLAN 2. Is your choice to completely delete WAN and VLAN 2; or leave them. WAN will simply keep making DHCP requests to nowhere.

Now, I've done it the way you described:

I went to Network > Switch and changed WAN port on VLAN 2 to off
Then, I added WAN port as untagged to VLAN1 (LAN).
I hit Save and Apply

But now I get a connection to the Internet only when I connect the Fritzbox on the LAN.

I want to connect the Fritzbox to the WAN, so I have four free LAN ports. In addition, the devices on the LAN ports should receive their IP from the DHCP server of the Fritzbox. LEDE should not have its own DHCP server.

Then turn it off.

Then add a gateway and DNS server to the LAN interface.

Here is the solution!
I found it in the article "Dumb AP/Access point only".
First I removed the firewall because it is already provided by the Fritzbox.

opkg update
opkg install ipset
/etc/init.d/firewall stop
/etc/init.d/Firewall disable
opkg remove firewall --force-removal-of-dependent-packages

Then I configured the network via the terminal.

vi etc/config/network

It is the original file in which lines with ' # ' must be commented out and some lines need to be changed. The changes are described in the comment.

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd8a:e5be:964e::/48'

config interface 'lan'
        option type 'bridge'
        #option ifname 'eth0.1'           original line
        option ifname 'eth0.1 eth1'     # changed line
        #option proto 'static'            original line
        option proto 'dhcp'             # changed line
        #option ipaddr '192.168.1.1'
        #option netmask '255.255.255.0'
        #option ip6assign '60'

#config interface 'wan'
        #option ifname 'eth0.2'
        #option proto 'dhcp'

#config interface 'wan6'
        #option ifname 'eth0.2'
        #option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '4 0 1 2 3 8t'     # write a 3 between 2 and 8

#config switch_vlan
        #option device 'switch0'
        #option vlan '2'
        #option ports '3 8t'

Now you have to disable the DHCP server.

uci set dhcp.lan.ignore=1
uci commit dhcp
/etc/init.d/dnsmasq restart

Now the changes are applied.

/etc/init.d/network reload

Now, Lamobo R1 works exactly as I want it.

If your problem has been solved, please consider marking the topic as [Solved].

How do I mark?

Just click the pencil symbol at the end of the topic line and prepend [Solved].