[SOLVED] Kimax u35wf openwrt updated final guide tested and working

Hi All,

after a long and hard way I've installed on my kimax u35wf openwrt with lede from github.com/arvati/lede-U35WF/releases (THIS IMAGE doesn't have root user enable DON'T USE!)

Look at the solution of this thread to load the right firmware

How many USB devices do you have attached?

Do you want to use the HDD as extroot?

which states on the main page

This release is just for historical purposes

There's a lot in that boot log that I don't recognize, such as the usbcore and raid lines. It could be device specific, or it could be somebody's hacked distro.

Given that v17 is effectively EOL, I'd move to an official release, if available. downloads.openwrt.org

You'll need USB mass-storage drivers, as well as the file system driver, as they are not standard in project-built images.


Hi Jeff

i don't think my device is offically supported my kimax u35ws is based on mediatek mt7620 that's why I'm on this distribution

I've below usb packages:
kmod-usb-core 4.4.92-1
kmod-usb-ledtrig-usbport 4.4.92-1
kmod-usb-ohci 4.4.92-1
kmod-usb-storage 4.4.92-1
kmod-usb-uhci 4.4.92-1
kmod-usb2 4.4.92-1
kmod-usb3 4.4.92-1

and file system
kmod-fs-ext4 4.4.92-1


I don't have any usb devices plugged, I have one usb port and one usb 3.0 port
this is a NAS and hd is plugged internally via sata.

I need to use HDD for ftp and samba access for other users I don't need this space to be used as filesystem for root

That build is pretty broken then.

What happens if you use http://downloads.openwrt.org/snapshots/targets/ramips/mt7620/openwrt-ramips-mt7620-kimax_u35wf-squashfs-sysupgrade.bin instead of an old (17.01) third party image which seems to have serious issues?

Installation instructions

1 Like

Currently I'm using lede interface to upgrade this error message:
The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

I'm trying to update via cli

What is the file name?

Typically you need *-sysupgrade.bin for a LEDE/OpenWrt upgrade.

Hi guys

good news, this image works like a charm: http://downloads.openwrt.org/snapshots/targets/ramips/mt7620/openwrt-ramips-mt7620-kimax_u35wf-squashfs-sysupgrade.bin

Installed via cli, but if you have orginal firmare do it via web interfaces than reboot and I got access from
than I set root password, ip default gateway, disabled dhcp, dns configuration, luci and finally with this tutorial:
I've mounted the internall HD
luci tutorial: https://openwrt.org/docs/guide-user/luci/luci.essentials

case closed a big THANK YOU to point me to the right direction

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.