[SOLVED] JBOOT recovery DLink_DWR-921 - ERROR

Hi guys, very bad mood here!

I upgraded from 18.06.0 to 18.06.4 via LuCI using a -sysupgrade.bin.
The upgrade went good but I loose my packages and I couldn't use my QMI connection for my mobile sim.
Looking for a way to use an old desktop to share via ethernet the internet connection in order to install the missing packages, I think I messed up with IP4 DHCP and stuff.

Now I can't connect to the router anymore.

If I boot the device I can see the ssid of the wireless connection but trying to connect to it fails, no IP is given.

I successfully entered the JBOOT recovery web interface to upload the -factory.bin but it gave me ERROR
I also tried the curl way but the response was the same.

Should I try to load the OEM firmware via JBOOT?
Should I try to downgrade the OpenWRT firmware?
What else can I do?

Depending on what you have done in the mean time, https://openwrt.org/de/doc/howto/generic.failsafe might still be available.

Be aware that user installed packages are always lost between sysupgrades, as they aren't binary compatible between different release versions and would break badly, if they were retained (up to bricking the whole device). In a situation where additional packages are required from the start, you could use imagebuilder (or building from source) to integrate them directly into your sysupgrade image - or feed them to opkg locally, at runtime/ after firstboot.

In filesafe mode I can ping but trying to telnet to it it respond "Unable to connect to remote host: Connection refused"

using JBOOT procedure I can telnet to but there are few commands, no mount_root

Try ssh instead of telnet.

From https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset

Note that modern OpenWrt uses always SSH, but early OpenWrt releases (15.05 and before) offered a telnet connection in this state but no SSH.

lazy me, I didn't try ssh early
ssh root@ip worked
I did a soft reset and now I'm back in the router.

How to share ethernet connection from my ubuntu desktop to the router?

On the Ubuntu Desktop
The wireless network (connected to my phone hotspot) has

I created a "shared" profile in my ethernet configuration that has

On the Router
I tried disabling DHCP and setting a static IP

but it didn't work (configuration not saved and reverted back)

What can I do?

Is there a better way to load the QMI packages needed to use my data SIM? (maybe the build way?)

If your problem (DWR-921 recovery) is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Actually we didn't fix the topic issue (Recovery gives Error)
We just found another way to get to the router.

Should I also open a new 3d?

Since this question is unrelated to the topic, please open a new topic for this.

Thanks every one for helping!

I was trying to find a way to install missing opkg locally but then I realised there was no need of it using command line for configuration


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.