[Solved] Issues with Sonos on LAN?

I have a LEDE router as a "dumb AP" wired LAN<->LAN with my "main" router and I haven't been able to get Sonos to work when wired to the LEDE lan port. This LEDE router is replacing a DDWRT dumb AP router which worked. Neither have FW, DNS, DHCP on, that is all on the main router. I am very confident I have just whiffed on the LEDE config. Hoping somebody has an idea or things to try. Here is the rough layout...

This works fine

main router(lan port) <-- wired --> (lan port) dumb DDWRT AP (lan port) <-- wired --> Sonos

When I plug in the LEDE router like so...

main router(lan port) <-- wired --> (lan port) dumb LEDE AP (lan port) <-- wired --> Sonos

After I jack the sonos in with the LEDE router I loose connectivity to the sonos. No regular Sonos functionality and can't even ping it (which I normally can). No ping even from the LEDE SSH console. The sonos get's it IP via a static DCHP on the main router.

Anyone have any ideas on what to look for or what to troubleshoot?


Switch and Vlan configs seem to be a first place to look. Is the port active and on the right Vlan? Can you plug anything else in and get it to work? Are the cables good?

Which model?

Router is an Asus RT-N16. I was poking around the confs last night. I want to say there were no "switch*" confs but I can't remember. I will look tonight and plug in a couple laptops to the LAN ports and see if this is not just Sonos.

Ok. Nothing to do with Sonos. I used a win laptop and a crappy ddwrt router as wired clients and similar results. Short version is anything wired into the LEDE router can ping the LEDE router but not each other or anything beyond the LEDE router. Oddly WIFI from LEDE works in all cases. Since I had hacked up the config before, I reset all config. Changed only the following, pwd, IP of LEDE router, Disabled DHCP, Disabled IPv6, stopped the FW, changed SSID, set WPA2 pwd. Of note, it is now using the default b43 driver (was using the kmod-brcm-wl before the reset)

Using this setup for a couple examples

main router(lan port) <-- wired --> (lan port) dumb LEDE router/AP 
													(lan port) <-- wired --> wired laptop
													(lan port) <-- wired --> ddwrt router
													<-- wifi --> wifi laptop

wifi laptop : can ping all routers/PCs
LEDE router : can ping all routers/PCs
wired laptop

  • can ping : LEDE router/AP and wifi laptop
  • can't ping : ddwrt router, main router

ddwrt router

  • can ping : LEDE router/AP and wifi laptop
  • can't ping : wired laptop, main router

main router

  • can ping : LEDE router, wifi laptop
  • can't ping : ddwrt router, wired laptop

I am clearly a LEDE noob but from this https://lede-project.org/docs/user-guide/switch_configuration it looks like there are no VLANs on this puppy (see below)? I am going to try and hack a vlan in for the LAN side next. Let me know what you guys think.

root@LEDE:~# ls -l /sys/class/net
lrwxrwxrwx    1 root     root             0 Oct 17 18:02 br-lan -> ../../devices/virtual/net/br-lan
lrwxrwxrwx    1 root     root             0 Jan  1  1970 eth0 -> ../../devices/bcma0:2/net/eth0
lrwxrwxrwx    1 root     root             0 Jan  1  1970 lo -> ../../devices/virtual/net/lo
lrwxrwxrwx    1 root     root             0 Oct 17 19:22 wlan0 -> ../../devices/bcma0:1/net/wlan0

root@LEDE:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option netmask ''
        option ip6assign '60'
        option ipaddr ''

Ok. So through hack-o-rama I eventually figured this out. In case it helps anyone else... I attempted to put in VLAN config and screwed them up badly enough I lost all connectivity. So ended up in Asus restore and TFTP-ed the LEDE image back on. In this flash/reboot I notice the power light flashing for a quite a while. I didn't notice that the first time. I walked away for a bit and connected in and... this time it has WAN, WAN6 and most importantly the network/switch section in Luci. None of these were there in the last flash at least not at the end. Maybe I starting hacking configs through Luci before it set itself up? Or maybe a bad flash? Seems less likely. Anyway, unsurprisingly with good VLAN configs everything works as you would expect.