[SOLVED] Issues with adding peers to wireguard interface

Hello everyone!
Lately I'm working on setting up a remote access to my home router using Wireguard and having this strange issue I can't seem to find a solution for. It seems like only last added peer (device) is able to connect and can actually be used. All previous ones can connect but don't seem to have any traffic activity like I have no access to anything. I'm not connecting them all at the same time, only one by one. If I remove the last entry, then the second last becomes the last one and can successfully connect and work normally without any additional changes.What am I doing wrong? All the peers were added in Luci interface and they have different IPs set. Thanks in advance.

Make sure every peer has a unique address and is /32 (in the allowed ips field).

Post your /etc/config/network file if you still need help (redact your keys and any public IP addresses)


Hello Peter and thanks for reply.
I've got to tell that a miracle just happened! I've re-added all my peers to post a network configuration and they all work as intended. I swear, I've done nothing different from what I did before multiple times, but this time it worked. Very strange. Hopefully, it was i glitch and it will now work stable. Anyways, thank you again for spending your time and willing to help. I appreciate it.
All the best.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.