I'm new to OpenWRT, I'm running a Netgear R7800 with NSS's 23.05 build. I have successfully flashed the router over ethernet and set up my network SSID and Passwords. The internet connectivity is great when I'm using wifi, but when I try to access 192.168.1.1 over wifi, I cannot connect.
I did some research and found that I am able to connect to 192.168.1.1 over wifi when I change my ipv4 settings on windows to:
However with these ipv4 settings enabled, I cannot access the internet and I am only able to access my openwrt control panel. Sorry for the noob question, what am I missing here? I'm assuming it has something to do with DHCP?
Thanks for any help
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </>
" button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
SSH doesn't work with default windows ipv4 settings, but I am able to SSH with my custom ipv4 settings. Here's the output:
BusyBox v1.36.1 (2023-11-09 20:20:48 UTC) built-in shell (ash)
_______ ________ __
| |.-----.-----.-----.| | | |.----.| |_
| - || _ | -__| || | | || _|| _|
|_______|| __|_____|__|__||________||__| |____|
|__| W I R E L E S S F R E E D O M
-----------------------------------------------------
OpenWrt 23.05-SNAPSHOT, r23711+22-cdc907abed
-----------------------------------------------------
root@OpenWrt:~# ubus call system board
{
"kernel": "5.15.146",
"hostname": "OpenWrt",
"system": "ARMv7 Processor rev 0 (v7l)",
"model": "Netgear Nighthawk X4S R7800",
"board_name": "netgear,r7800",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "23.05-SNAPSHOT",
"revision": "r23711+22-cdc907abed",
"target": "ipq806x/generic",
"description": "OpenWrt 23.05-SNAPSHOT r23711+22-cdc907abed"
}
}
root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd13:3a09:e677::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth1.1'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wan'
option device 'eth0.2'
option proto 'dhcp'
config interface 'wan6'
option device 'eth0.2'
option proto 'dhcpv6'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 4 6t'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '5 0t'
root@OpenWrt:~# cat /etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
option channel '36'
option band '5g'
option htmode 'VHT160'
option country 'US'
option cell_density '0'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'REDACTED'
option encryption 'psk2'
option key 'REDACTED'
config wifi-device 'radio1'
option type 'mac80211'
option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
option channel '1'
option band '2g'
option htmode 'HT20'
option disabled '1'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'none'
root@OpenWrt:~# cat /etc/config/dhcp
config dnsmasq
option domainneeded '1'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option cachesize '1000'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option localservice '1'
option ednspacket_max '1232'
option confdir '/tmp/dnsmasq.d'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
option ra_slaac '1'
list ra_flags 'managed-config'
list ra_flags 'other-config'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
config host
option duid 'REDACTED'
option mac 'REDACTED'
config host
option name 'REDACTED'
option duid 'REDACTED'
option mac 'REDACTED'
root@OpenWrt:~# cat /etc/config/firewall
config defaults
option syn_flood '1'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
config zone
option name 'lan'
list network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
config zone
option name 'wan'
list network 'wan'
list network 'wan6'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
config forwarding
option src 'lan'
option dest 'wan'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'
config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'
config include 'nss_ecm'
option type 'script'
option path '/etc/firewall.d/qca-nss-ecm'
option family 'any'
option reload '1'
root@OpenWrt:~#
Also my network card is an Intel AX201.
What are these for?
This may be causing the problem.... try deleting that section
And did you add this line? Probably should be deleted, too.
.
You said to redact anything that was personal, so the SSID, password, MAC addresses, and duids I redacted from the post. Would it be better if I didn't redact them? And no I don't believe I personally added that line, I use luci to configure the router. Not sure how to delete over SSH.
oddwindow:
You said to redact anything that was personal, so the SSID, password, MAC addresses, and duids I redacted from the post.
Yes... I was asking not what the values are, but rather what the purpose of those lines are? They may be causing the DHCP process to fail. Remove those host config sections and then restart the router and try DHCP again.
Ok, I am trying to use vi over SSH on the windows command prompt and my connection resets after a few seconds... How should I go about editing these files? Am I able to do it through luci?
That is not normal, and would not be caused by any DHCP issues.
Have you tried ethernet?
When using ethernet I am able to access the router and the internet at the same time. When using wifi I can only access one or the other depending on what my ipv4 settings are.
I am connected over ethernet now, I'll try to remove those lines.
I think you've got something else going on that is more important... if ethernet is working properly but wifi is dropping frequently even when you're using a static IP, it says something is wrong with wifi.
Do other wifi client devices have any issues connecting to the router?
1 Like
My iPhone can connect to 192.168.1.1 and the internet at the same time, yes.
Ok... then I suspect the problem is the wifi in your computer that's having difficulty.
1 Like
I just deleted those lines with winscp over ethernet. I also thought about how it might be my computer that is the problem so I "forgot" all my networks and reconnected, it appears to be working now.
I am going to restart my router and PC and see if it continues to work after a reboot.
great!
If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks!
1 Like
Yeah it appears to be working now, guess it was my pc...
Turning it off and back on worked. Thanks for your help...
1 Like
system
Closed
October 1, 2024, 6:15am
16
This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.