[solved] IPV6 reservation and dualbooting, advice wanted

When my laptop, normally running Linux, is rebooted into Windows, the IPV6 reservation is successfully reassigned to WIndows. Not so when going back to Linux: in this case, I must stop odhcpd, clear the cache file and restart it, otherwise the hostname would still point to the reservation even though it is not in use by the client.

When setting up the reservation initially, I had copied the DUID from Windows to Linux with the intention of having a stable reservation and it seemed to work fine, right until I started dualbooting more often.

Couple of questions:

  1. I suspect Linux is releasing the reservation when rebooting but Windows isn't: how do I verify this hypothesis?

  2. what would be a better way to handle this situation? Ideally with one IPV6 address per host regardless of the OS but I'm fine with the laptop under Linux getting the expected address and Windows using something else.

1 Like

Try to run as admin before rebooting to Linux:

ipconfig /release
ipconfig /release6

It should be possible to customize DUID in the NM connection settings:

1 Like

@vgaetera thanks for the reply. So, I had already set the DUID via nmcli on Linux and it matches with the router and with what I can see while under Windows.

Come to think of it, since Linux is my primary OS on the laptop (and the desktop as well), when I need to use Windows temporarily I normally hibernate Linux, do a fresh boot into Windows, shut it down once I am done and then thaw Linux.

Given that this is quite convenient and that I don't care if Windows gets a non-reserved IPV6, any ideas? I'm not sure you can easily convince Windows to use a specific DUID but it looks like the best shot.

1 Like

Does it help if you force DHCP/DHCPv6 release?
Perhaps you should minimize the lease time.
Or specify a different DUID and/or MAC for a predictable result.
I don't really have Windows, so I can only guess. :sweat_smile:

1 Like

Have linux use stable privacy (default in network manager) and windows use whatever it wants. Give two names foo and foowin

1 Like

Nope, releasing from Windows has no effect whatsoever.
I'm going to try @dlakelan 's suggestion and get back with the results.

1 Like

Grrr... now I get the same IPV4 address (of course, same MAC, silly me!) when going back to Linux. Plus the reverse is always the "windows" name, again because of shared MAC but different DUID.
Anyway, here is how you tame Windows for DUID.

Simple... Turn off ipv4 :wink:

So, if I want to achieve predictable behavior, I'd probably use a different MAC, DHCP client ID, DUID and whatever else is leading to a collision, since those parameters should be easily to modify with NM.

@dlakelan :smiley:

@vgaetera For the moment I enabled "random MAC addresses" in Windows, it seems to be working.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.