[SOLVED] IPV6 on LAN (6in4-henet)


#1

Hi,
I have device "TP-Link TL-WR841N/ND v8" with firmware "LEDE Reboot 17.01.4 r3560-79f57e422d / LuCI lede-17.01 branch (git-17.290.79498-d3f0685)".
I’m using Ipv6 with HENET tunnel-broker, in my LAN I have two main devices PC and NAS.
I’m using dualboot on my PC. There is no any problem, then my PC booting with Win 7 Pro x64, ipv6 dns resolve, tcp connect and ping Ok.

ipconfig
Настройка протокола IP для Windows


Ethernet adapter Подключение по локальной сети:

   DNS-суффикс подключения . . . . . : lan
   IPv6-адрес. . . . . . . . . . . . : 2001:470:7870::121
   IPv6-адрес. . . . . . . . . . . . : 2001:470:7870:0:98b5:3790:1314:527a
   IPv6-адрес. . . . . . . . . . . . : fde2:f422:369::121
   IPv6-адрес. . . . . . . . . . . . : fde2:f422:369:0:98b5:3790:1314:527a
   Временный IPv6-адрес. . . . . . . : 2001:470:7870:0:b166:9843:3972:195a
   Временный IPv6-адрес. . . . . . . : fde2:f422:369:0:b166:9843:3972:195a
   Локальный IPv6-адрес канала . . . : fe80::98b5:3790:1314:527a%12
   IPv4-адрес. . . . . . . . . . . . : 192.168.1.121
   Маска подсети . . . . . . . . . . : 255.255.255.0
   Основной шлюз. . . . . . . . . : fe80::92f6:52ff:fef8:186e%12
                                       192.168.1.1

Ethernet adapter VirtualBox Host-Only Network:

   DNS-суффикс подключения . . . . . :
   Локальный IPv6-адрес канала . . . : fe80::99ad:be3b:90ad:3b87%13
   IPv4-адрес. . . . . . . . . . . . : 192.168.56.1
   Маска подсети . . . . . . . . . . : 255.255.255.0
   Основной шлюз. . . . . . . . . :

Туннельный адаптер isatap.lan:

   Состояние среды. . . . . . . . : Среда передачи недоступна.
   DNS-суффикс подключения . . . . . : lan

Туннельный адаптер isatap.{1193FAAA-33D8-41AF-B706-E3E95782A44A}:

   Состояние среды. . . . . . . . : Среда передачи недоступна.
   DNS-суффикс подключения . . . . . :
route
===========================================================================
Список интерфейсов
 12...14 da e9 f4 9f 24 ......Realtek PCIe GbE Family Controller
 13...0a 00 27 00 00 0d ......VirtualBox Host-Only Ethernet Adapter
  1...........................Software Loopback Interface 1
 11...00 00 00 00 00 00 00 e0 Адаптер Microsoft ISATAP
 14...00 00 00 00 00 00 00 e0 Адаптер Microsoft ISATAP #2
===========================================================================

IPv4 таблица маршрута
===========================================================================
Активные маршруты:
Сетевой адрес           Маска сети      Адрес шлюза       Интерфейс  Метрика
          0.0.0.0          0.0.0.0      192.168.1.1    192.168.1.121     10
        127.0.0.0        255.0.0.0         On-link         127.0.0.1    306
        127.0.0.1  255.255.255.255         On-link         127.0.0.1    306
  127.255.255.255  255.255.255.255         On-link         127.0.0.1    306
      192.168.1.0    255.255.255.0         On-link     192.168.1.121    266
    192.168.1.121  255.255.255.255         On-link     192.168.1.121    266
    192.168.1.255  255.255.255.255         On-link     192.168.1.121    266
     192.168.56.0    255.255.255.0         On-link      192.168.56.1    266
     192.168.56.1  255.255.255.255         On-link      192.168.56.1    266
   192.168.56.255  255.255.255.255         On-link      192.168.56.1    266
        224.0.0.0        240.0.0.0         On-link         127.0.0.1    306
        224.0.0.0        240.0.0.0         On-link     192.168.1.121    266
        224.0.0.0        240.0.0.0         On-link      192.168.56.1    266
  255.255.255.255  255.255.255.255         On-link         127.0.0.1    306
  255.255.255.255  255.255.255.255         On-link     192.168.1.121    266
  255.255.255.255  255.255.255.255         On-link      192.168.56.1    266
===========================================================================
Постоянные маршруты:
  Отсутствует

IPv6 таблица маршрута
===========================================================================
Активные маршруты:
 Метрика   Сетевой адрес            Шлюз
 12    266 ::/0                     fe80::92f6:52ff:fef8:186e
  1    306 ::1/128                  On-link
 12    266 2001:470:7870::/48       fe80::92f6:52ff:fef8:186e
 12     18 2001:470:7870::/64       On-link
 12    266 2001:470:7870::121/128   On-link
 12    266 2001:470:7870:0:98b5:3790:1314:527a/128
                                    On-link
 12    266 2001:470:7870:0:b166:9843:3972:195a/128
                                    On-link
 12    266 fde2:f422:369::/48       fe80::92f6:52ff:fef8:186e
 12     18 fde2:f422:369::/64       On-link
 12    266 fde2:f422:369::121/128   On-link
 12    266 fde2:f422:369:0:98b5:3790:1314:527a/128
                                    On-link
 12    266 fde2:f422:369:0:b166:9843:3972:195a/128
                                    On-link
 12    266 fe80::/64                On-link
 13    266 fe80::/64                On-link
 12    266 fe80::98b5:3790:1314:527a/128
                                    On-link
 13    266 fe80::99ad:be3b:90ad:3b87/128
                                    On-link
  1    306 ff00::/8                 On-link
 12    266 ff00::/8                 On-link
 13    266 ff00::/8                 On-link
===========================================================================
Постоянные маршруты:
  Отсутствует

I have the problem with my linux on PC (ArchLinux latest) and NAS (Synology=Linux):
ipv6 dns resolve Ok, but ping (timeout), tcp connect (timeout) - not working. Same behaviour also on NAS. PC Network configured by netctl

cat /etc/netctl/my_dhcp
Description='A basic dhcp ethernet connection'
Interface=enp5s0
Connection=ethernet
IP=dhcp
#DHCPClient=dhcpcd
#DHCPReleaseOnStop=no
## for DHCPv6
#IP6=dhcp // I tried to uncomment, not fix the problem
#DHCP6Client=dhclient
## for IPv6 autoconfiguration
#IP6=stateless // I tried to uncomment, not fix the problem

ExecUpPost='/usr/bin/ip link set enp5s0 mtu 9000'
ping -c 3 google.com                                                                                                                                                                                                                             ~
PING google.com(ord37s18-in-x0e.1e100.net (2607:f8b0:4009:805::200e)) 56 data bytes

--- google.com ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 32ms

telnet google.com 80                                                                                                                                                                                                                             ~
Trying 2607:f8b0:4009:805::200e...

asd
sdf
sdf
sdf
Connection failed: Время ожидания соединения истекло
Trying 172.217.4.206...
Connected to google.com.
Escape character is '^]'.
HTTP/1.0 400 Bad Request
Content-Type: text/html; charset=UTF-8
...
ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp5s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 9000 qdisc fq_codel state UP group default qlen 1000
    link/ether 14:da:e9:f4:9f:24 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.121/24 brd 192.168.1.255 scope global noprefixroute enp5s0
       valid_lft forever preferred_lft forever
    inet6 fde2:f422:369:0:16da:e9ff:fef4:9f24/64 scope global dynamic mngtmpaddr
       valid_lft forever preferred_lft forever
    inet6 2001:470:7870:0:16da:e9ff:fef4:9f24/64 scope global dynamic mngtmpaddr
       valid_lft forever preferred_lft forever
    inet6 fe80::16da:e9ff:fef4:9f24/64 scope link
       valid_lft forever preferred_lft forever

Router configuration:

cat /etc/config/network
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde2:f422:0369::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option igmp_snooping '1'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0'
        option _orig_ifname 'eth0'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option username 'pppoe-login'
        option password 'pppoe-pass'
        option ipv6 'auto'
        option peerdns '0'
        option dns '139.99.96.146 92.222.97.145'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'

config interface 'henet'
        option proto '6in4'
        option peeraddr '216.66.84.46'
        option ip6addr '2001:470:1f14:cb::2/64'
        option tunnelid 'my_id'
        option username 'my_username'
        option password 'my_password'
        option ip6prefix '2001:470:7870::/48'
cat /etc/config/dhcp
config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option localservice '1'
        option nonwildcard '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option ra 'server'
        option dhcpv6 'server'
        option ra_management '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

config host
        option name 'pc'
        option dns '1'
        option mac '14:da:e9:f4:9f:24'
        option ip '192.168.1.121'

config host
        option name 'DiskStation'
        option dns '1'
        option mac '00:11:32:1b:79:82'
        option ip '192.168.1.124'
cat /etc/config/firewall
config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan henet'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

The result of independent attempts to solve the problem (and some magic):
https://openwrt.org/docs/guide-user/network/ipv6/start#downstream_configuration_for_lan-interfaces
https://wiki.archlinux.org/index.php/IPv6

ping ff02::1%enp5s0
PING ff02::1%enp5s0(ff02::1%enp5s0) 56 data bytes
64 bytes from fe80::16da:e9ff:fef4:9f24%enp5s0: icmp_seq=1 ttl=64 time=0.038 ms
64 bytes from fe80::211:32ff:fe1b:7981%enp5s0: icmp_seq=1 ttl=64 time=0.238 ms (DUP!)
64 bytes from fe80::92f6:52ff:fef8:186e%enp5s0: icmp_seq=1 ttl=64 time=0.466 ms (DUP!)
64 bytes from fe80::220:85ff:fef7:1682%enp5s0: icmp_seq=1 ttl=1 time=1.74 ms (DUP!)
64 bytes from fe80::16da:e9ff:fef4:9f24%enp5s0: icmp_seq=2 ttl=64 time=0.046 ms
64 bytes from fe80::211:32ff:fe1b:7981%enp5s0: icmp_seq=2 ttl=64 time=0.202 ms (DUP!)
64 bytes from fe80::92f6:52ff:fef8:186e%enp5s0: icmp_seq=2 ttl=64 time=0.502 ms (DUP!)
64 bytes from fe80::220:85ff:fef7:1682%enp5s0: icmp_seq=2 ttl=1 time=1.69 ms (DUP!)
64 bytes from fe80::16da:e9ff:fef4:9f24%enp5s0: icmp_seq=3 ttl=64 time=0.048 ms
64 bytes from fe80::211:32ff:fe1b:7981%enp5s0: icmp_seq=3 ttl=64 time=0.192 ms (DUP!)
64 bytes from fe80::92f6:52ff:fef8:186e%enp5s0: icmp_seq=3 ttl=64 time=0.521 ms (DUP!)
64 bytes from fe80::220:85ff:fef7:1682%enp5s0: icmp_seq=3 ttl=1 time=2.24 ms (DUP!)
64 bytes from fe80::16da:e9ff:fef4:9f24%enp5s0: icmp_seq=4 ttl=64 time=0.025 ms
64 bytes from fe80::211:32ff:fe1b:7981%enp5s0: icmp_seq=4 ttl=64 time=0.208 ms (DUP!)
64 bytes from fe80::92f6:52ff:fef8:186e%enp5s0: icmp_seq=4 ttl=64 time=0.490 ms (DUP!)
64 bytes from fe80::220:85ff:fef7:1682%enp5s0: icmp_seq=4 ttl=1 time=2.17 ms (DUP!)
^C
--- ff02::1%enp5s0 ping statistics ---
4 packets transmitted, 4 received, +12 duplicates, 0% packet loss, time 8ms
rtt min/avg/max/mdev = 0.025/0.676/2.238/0.769 ms

Ping ipv6 address on HENET interface. (timeout)

ping 2001:470:1f14:cb::2
^CPING 2001:470:1f14:cb::2(2001:470:1f14:cb::2) 56 data bytes

--- 2001:470:1f14:cb::2 ping statistics ---
2 packets transmitted, 0 received, 100% packet loss, time 11ms

Ping ipv6 address on lan (router address) SUCCESS!

ping 2001:470:7870::1
PING 2001:470:7870::1(2001:470:7870::1) 56 data bytes
64 bytes from 2001:470:7870::1: icmp_seq=1 ttl=64 time=0.840 ms
64 bytes from 2001:470:7870::1: icmp_seq=2 ttl=64 time=0.321 ms
64 bytes from 2001:470:7870::1: icmp_seq=3 ttl=64 time=0.328 ms
^C
--- 2001:470:7870::1 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 25ms
rtt min/avg/max/mdev = 0.321/0.496/0.840/0.243 ms

After that ipv6 work:

ping 2001:470:1f14:cb::2
PING 2001:470:1f14:cb::2(2001:470:1f14:cb::2) 56 data bytes
64 bytes from 2001:470:1f14:cb::2: icmp_seq=1 ttl=64 time=0.297 ms
64 bytes from 2001:470:1f14:cb::2: icmp_seq=2 ttl=64 time=0.330 ms
64 bytes from 2001:470:1f14:cb::2: icmp_seq=3 ttl=64 time=0.283 ms
^C
--- 2001:470:1f14:cb::2 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 37ms
rtt min/avg/max/mdev = 0.283/0.303/0.330/0.024 ms
ping google.com
PING google.com(ord37s18-in-x0e.1e100.net (2607:f8b0:4009:805::200e)) 56 data bytes
64 bytes from ord37s18-in-x0e.1e100.net (2607:f8b0:4009:805::200e): icmp_seq=1 ttl=52 time=264 ms
64 bytes from ord37s18-in-x0e.1e100.net (2607:f8b0:4009:805::200e): icmp_seq=2 ttl=52 time=264 ms
64 bytes from ord37s18-in-x0e.1e100.net (2607:f8b0:4009:805::200e): icmp_seq=3 ttl=52 time=264 ms
^C
--- google.com ping statistics ---
4 packets transmitted, 3 received, 25% packet loss, time 7ms
rtt min/avg/max/mdev = 263.737/263.793/263.837/0.594 ms

Absolutely the same behavior on the NAS. Then I manually ping the router (Ipv6 lan address), Ipv6 starts to work correctly.
Solution is temprorary, after some time ipv6 stops working, after reboot too. (same on NAS)
In more detail: after a while, it stops working, using the same method — pinging the router — work is no longer being restored, restarting the interface helps (netctl restart my_dhcp)

Friends, I really hope for good advice, I know a little about it.
And I really apologize for my bad English.


#2

You must enable IPv6 stateless configuration (SLAAC)


#3

Just tried = did not solve the problem.
Using this:

Example configuration section for SLAAC alone
root@lede:/# cat /etc/config/dhcp
config dhcp lan
option dhcpv6 disabled
option ra server

My router current configuration:

root@LEDE:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option localservice '1'
        option nonwildcard '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option ra 'server'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

config host
        option name 'pc'
        option dns '1'
        option mac '14:da:e9:f4:9f:24'
        option ip '192.168.1.121'

config host
        option name 'DiskStation'
        option dns '1'
        option mac '00:11:32:1b:79:82'
        option ip '192.168.1.124'

Screenshot_2018-11-08%20LEDE%20-%20Interfaces%20-%20LuCI

Arch linux log on this:

ip addr                                                                                                                                                                                                                                              ~
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp5s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 9000 qdisc fq_codel state UP group default qlen 1000
    link/ether 14:da:e9:f4:9f:24 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.121/24 brd 192.168.1.255 scope global noprefixroute enp5s0
       valid_lft forever preferred_lft forever
    inet6 fde2:f422:369:0:2358:e28b:9ded:b905/64 scope global mngtmpaddr noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 2001:470:7870:0:6630:f7e6:d85d:970c/64 scope global mngtmpaddr noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::d604:211a:f831:6864/64 scope link 
       valid_lft forever preferred_lft forever
ping -c 3 google.com                                                                                                                                                                                                                                 ~
PING google.com(ord37s18-in-x0e.1e100.net (2607:f8b0:4009:805::200e)) 56 data bytes

--- google.com ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 22ms

[1]

#4

Screenshot_2018-11-08%20LEDE%20-%20Interfaces%20-%20LuCI%201

In this configuration, the temprorary solution also works.
Then I ping ipv6 lan address of the router (2001:470:7870::1) - ipv6 start to work well (like in Win 7).
Commands entered sequentially.

titan@titan-home-linux> ip addr                                                                                                                                                                                                                                              ~
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp5s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 9000 qdisc fq_codel state UP group default qlen 1000
    link/ether 14:da:e9:f4:9f:24 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.121/24 brd 192.168.1.255 scope global noprefixroute enp5s0
       valid_lft forever preferred_lft forever
    inet6 fde2:f422:369:0:2358:e28b:9ded:b905/64 scope global mngtmpaddr noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 2001:470:7870:0:6630:f7e6:d85d:970c/64 scope global mngtmpaddr noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::d604:211a:f831:6864/64 scope link 
       valid_lft forever preferred_lft forever
titan@titan-home-linux> ping -c 3 google.com                                                                                                                                                                                                                                 ~
PING google.com(ord37s18-in-x0e.1e100.net (2607:f8b0:4009:805::200e)) 56 data bytes

--- google.com ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 22ms

[1] titan@titan-home-linux> ping 2001:470:7870::1                                                                                                                                                                                                                            ~
PING 2001:470:7870::1(2001:470:7870::1) 56 data bytes
64 bytes from 2001:470:7870::1: icmp_seq=1 ttl=64 time=0.893 ms
64 bytes from 2001:470:7870::1: icmp_seq=2 ttl=64 time=0.321 ms
64 bytes from 2001:470:7870::1: icmp_seq=3 ttl=64 time=0.297 ms
^C
--- 2001:470:7870::1 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 26ms
rtt min/avg/max/mdev = 0.297/0.503/0.893/0.276 ms
titan@titan-home-linux> ping -c 3 google.com                                                                                                                                                                                                                                 ~
PING google.com(ord37s18-in-x0e.1e100.net (2607:f8b0:4009:805::200e)) 56 data bytes
64 bytes from ord37s18-in-x0e.1e100.net (2607:f8b0:4009:805::200e): icmp_seq=1 ttl=52 time=251 ms
64 bytes from ord37s18-in-x0e.1e100.net (2607:f8b0:4009:805::200e): icmp_seq=2 ttl=52 time=251 ms
64 bytes from ord37s18-in-x0e.1e100.net (2607:f8b0:4009:805::200e): icmp_seq=3 ttl=52 time=251 ms

--- google.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 5ms
rtt min/avg/max/mdev = 250.524/250.593/250.715/0.417 ms
titan@titan-home-linux>   

#5

Clear the ULA prefix


#6

Many thanks, this solved the problem (tested on Arch and NAS), thanks again.
P.S. I will google: what is it and why it helps. (And why on Windows ipv6 work well)


#7

Need another tip.
The problem did not fixed completely.
Now the behavior is:
If the router is already running and the pc starts up, the operating system (It does not matter Linux or Windows) receives the settings of the ipv6 network correctly, but the problem reappears (dns ok, ping and connect fail). But if I reboot router while pc already running problem disappears. If I restart (manual) interface on pc - ipv6 stil work right.

For testing I tried this, but it didn't help
config dhcp 'lan'
...
option ra_default '1'
root@LEDE:~# cat /etc/config/dhcp 

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option localservice '1'
        option nonwildcard '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option ra_default '1'
        option ra 'server'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

config host
        option name 'pc'
        option dns '1'
        option mac '14:da:e9:f4:9f:24'
        option ip '192.168.1.121'

config host
        option name 'DiskStation'
        option dns '1'
        option mac '00:11:32:1b:79:82'
        option ip '192.168.1.124'


#8

The problem above is localized only on the pc. It's related to it's network settings.
Phone (Android), NAS (Synology) work good with ipv6.
The solution provided by @LGA1150 fully working.
P.S.
I do not know, for now, why, but
If the computer boots up under Win 7: then the network settings are obtained correctly, but the network does not work. After 10+ minutes the problem is solved by itself.
If pc boot under Linux, the network settings also are obtained correctly but the network does not start to work, even after a long time.
If I manually ping lan ipv6 address of the router, then the network works well.
NAS Log (it work well):

admin@DiskStation:~$ ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: sit0: <NOARP> mtu 1480 qdisc noop state DOWN 
    link/sit 0.0.0.0 brd 0.0.0.0
3: eth0: <BROADCAST,MULTICAST,SLAVE,UP,LOWER_UP> mtu 9000 qdisc pfifo_fast master bond0 state UP qlen 1000
    link/ether 00:11:32:1b:79:81 brd ff:ff:ff:ff:ff:ff
4: eth1: <BROADCAST,MULTICAST,SLAVE,UP,LOWER_UP> mtu 9000 qdisc pfifo_fast master bond0 state UP qlen 1000
    link/ether 00:11:32:1b:79:82 brd ff:ff:ff:ff:ff:ff
5: bond0: <BROADCAST,MULTICAST,MASTER,UP,LOWER_UP> mtu 9000 qdisc noqueue state UP 
    link/ether 00:11:32:1b:79:81 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.124/24 brd 192.168.1.255 scope global bond0
       valid_lft forever preferred_lft forever
    inet6 2001:470:7870:0:211:32ff:fe1b:7981/64 scope global dynamic 
       valid_lft forever preferred_lft forever
    inet6 2001:470:1f15:cd:211:32ff:fe1b:7981/64 scope global deprecated dynamic 
       valid_lft 4436sec preferred_lft 0sec
    inet6 fe80::211:32ff:fe1b:7981/64 scope link 
       valid_lft forever preferred_lft forever
admin@DiskStation:~$ ip route
default via 192.168.1.1 dev bond0  src 192.168.1.124 
192.168.1.0/24 dev bond0  proto kernel  scope link  src 192.168.1.124 
admin@DiskStation:~$ ip -6 route
2001:470:1f15:cd::/64 dev bond0  proto kernel  metric 256  expires 4415sec mtu 1280
2001:470:7870::/64 dev bond0  proto kernel  metric 256 
fe80::/64 dev bond0  proto kernel  metric 256  mtu 1280
default via fe80::92f6:52ff:fef8:186e dev bond0  metric 1024

Arch-Linux log (buggy)
Strange for me:

  1. mngtmpaddr flag
  2. pref medium
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp5s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 9000 qdisc fq_codel state UP group default qlen 1000
    link/ether 14:da:e9:f4:9f:24 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.121/24 brd 192.168.1.255 scope global noprefixroute enp5s0
       valid_lft forever preferred_lft forever
    inet6 2001:470:7870:0:16da:e9ff:fef4:9f24/64 scope global dynamic mngtmpaddr 
       valid_lft forever preferred_lft forever
    inet6 2001:470:1f15:cd:16da:e9ff:fef4:9f24/64 scope global deprecated dynamic mngtmpaddr 
       valid_lft 4184sec preferred_lft 0sec
    inet6 fe80::16da:e9ff:fef4:9f24/64 scope link 
       valid_lft forever preferred_lft forever
titan@titan-home-linux> ip route                                                                                                                                                                                                                                             ~
default via 192.168.1.1 dev enp5s0 proto dhcp src 192.168.1.121 metric 202 
192.168.1.0/24 dev enp5s0 proto dhcp scope link src 192.168.1.121 metric 202 
titan@titan-home-linux> ip -6 route                                                                                                                                                                                                                                          ~
::1 dev lo proto kernel metric 256 pref medium
2001:470:1f15:cd::/64 dev enp5s0 proto kernel metric 256 expires 4153sec pref medium
2001:470:7870::/64 dev enp5s0 proto kernel metric 256 pref medium
fe80::/64 dev enp5s0 proto kernel metric 256 pref medium
default via fe80::92f6:52ff:fef8:186e dev enp5s0 proto ra metric 1024 expires 1424sec hoplimit 64 pref medium