[Solved] IPQ4019: can only enable 2ghz radio

Hi everyone,

I'm having fairly good success using OpenWRT on my old FritzBox 7530 (https://openwrt.org/toh/avm/avm_fritz_box_7530), but am encountering an almost-final unfortunate problem:

I can use the 2ghz radio very well, but as soon as I enable the 5ghz radio, all radios fail to connect.

Having a search around the forum, it seems quite like this is just a limitation:

I could probably live without 5ghz right now, but thought I should ask unless it can be investigated. Here are my configs:

/etc/config/network:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'
	option peerdns '0'
	list dns '1.1.1.1'
	list dns '1.0.0.1'
	list dns '8.8.8.8'
	option ipv6 '0'
	option delegate '0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0'

config device
	option name 'eth0'
	option promisc '1'

config interface 'link'
	option proto 'static'
	option device 'br-lan'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'

config device
	option name 'wlan1'
	option promisc '1'

config interface 'internal'
	option proto 'static'
	option ipaddr '192.168.100.1'
	option netmask '255.255.255.0'

/etc/config/wireless:

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/a000000.wifi'
	option band '2g'
	option cell_density '0'
	option channel 'auto'
	option country 'GB'
	option htmode 'HT20'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/a800000.wifi'
	option band '5g'
	option cell_density '0'
	option country 'GB'
	option channel '36'
	option htmode 'HT40'
	option disabled '1'

config wifi-iface 'internal5g'
	option device 'radio1'
	option mode 'ap'
	option network 'internal'
	option encryption 'psk2'
	option key '<key>'
	option ssid '<5ghz net>'
	option wmm '0'
	option disabled '1'

config wifi-iface 'internal2g'
	option device 'radio0'
	option mode 'ap'
	option ssid '<2ghz>'
	option encryption 'psk2'
	option key '<key>'
	option network 'internal'

In the above, if I just remove the option disabled '1' for the 5ghz radio, I lose all connectivity.

Hope someone can help! Thanks in advance

Since your internal network has no bridge associated, you can only connect one hardware device (an AP on one band) to it. Convert internal to a bridge with a br-internal (follow the example of lan and br-lan) then you can have APs on both bands bridged into the same network.

@mk24 Fantastic! What a succinct and understandable explanation. It works! Please excuse my limited knowledge of all this stuff; already learnt quite a few things just getting my hands dirty with this

Have a nice week :grinning:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.