[SOLVED] Installing OpenWrt 18.06.1 on Alfa R36 router

Hi, after two days of trying, I'm posting to see if somebody can help me out.

I know installation on this one is through uboot with a tftp server. Ok. I have everything under control, almost, but one thing is driving me mad.

When uboot is starting and I'm watching the console output on the terminal, when it asks:

Please choose the operation:
1: Load system code to SDRAM via TFTP.
2: Load system code then write to Flash via TFTP.
3: Boot system code via Flash (default).

It autoselects option 3), the default one. But without giving me any option to enter number 2 which is the one to write the firmware through tftp. Here you can see the output at that moment:


I have already read many times the 4 pages on the old forum about R36:

...the thing is that thinking that I could have some problem with my serial devices... I have check with two different USB TTLs using putty from windows to get the console, but because they both do exactly what I'm telling you, as I third try I'm doing it with a raspberry pi 2, through raspbian, with minicom serial software and connecting it through serial GPIOS to the alfa_R36 and... ...

it DOES just THE SAME!!!. ...lightspeed uboot autoselecting option 3 without time to press anything. I have tried pressing key '2' even before powering the R36, but no luck, uboot always starting with flash image.

note: after trying many times with original alfa firmware installed v1.3.0.0RA(Feb 17 2012), I finally update to latest alfa version v2.32(2017) to see if that change something on the uboot start sequence, but it does the same.

edit: (I already did a loopback test of the terminal, conecting Tx to Rx directly and what I press on the keyboard are correctly typed on terminal screen, so cable conections seem right).

Tested with diferrent terminal programs, putty(windows), minicom, picocom, screen (linux)... everyone behaves the same.

Any help to try something different will be very appreciated. Thanks!.

1 Like

I'm answering to myself, in case somebody find the answer useful.

Ok, I have solve the problem buying a RS232 TTL (instead of the usb ttl converters or the raspberry pi throguh gpios I was trying before). I'm not publishing the ebay item because that will expire, but the description is: "RS232 To TTL Converter Module MAX3232 with LED" and the pictures:


and plugged in my old notebook with rs232 interface:

With this ttl and all four wires connected to the ttl and the r36 on the other side, the u-boot does the pause for entering option 2 and be able to write flash from file through tftp. (not like before that autoselects option '3' to start router firmware directly)

I would like to mention that I think the problem was a lack of power in my previous configuration. In my previous tests I was connecting only 3 wires, and not the vcc one. With this ttl I connected all four cables and the interaction went smooth. Perfect for pressing option '2' in the first try and for pressing 'enter' at the end of writing firm and getting into the telnet console without a hassle.

I read in many places that you only need 3 cables connected, and that connecting vcc could damage your router. That's why in my previous trys, with my two usb ttl's and the raspberry I didn't dare to connect the vcc power. When I saw a video on youtube with an Alfa R36 being updated using a VERY similar ttl RS232, and being updated without problem, I decided to buy one of those and plug all 4 cables like in the video including the vcc. It works like a charm this time.
If they didn't fry their router with this rs232 ttl, I wouldn't fry mine. So, I buy one of thouse at a very cheap price from ebay. Hope it helps someone.

edit: Just to say that after some days testing, the openwrt 18.06.1 on alfa r36 is unusable. It works, but I have many problems with wifi stability, etc. getting back alfa firmware on this one to use it as a normal wifi extender.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.