[Solved] Installing an 8MB package onto 10MB of free space failed. Workaround?

Hey fellas

I'm getting free space errors when trying to install an 8MB package even though I have over 10MB of free space.

Do you have any suggestion on how I can easily and temporarily get enough space to be able to extract the package and then clean up afterwards?

I have a USB port but to mount a drive I need lots of packages installed eating up those leftover 2MB. I was wondering if there's an easier solution?

There's plenty of RAM left unused. Can I use that? Does that require more stuff to be installed than what's needed to mount a USB drive?

I've never built an Openwrt image so I'd rather not go down that route, yet. I have used Extroot, but I was thinking that if I have enough space for the "end result", then why not just try to just get a workaround for just the install process?


let's see the output of

ubus call system board
df -h

The way this works is that you install a few packages from either a complete fresh image, or build your own image with them included. There is usually enough space for the required packages, but if there isn't, a custom image can omit things like LuCI which can be installed later. Here's the extroot documentation.

No... it wouldn't be persistent (it disappears on reboot or power cycle).

Building an image is super simple now -- you can use the firmware selector tool to create a custom image.

1 Like

Holy moly that was easy to request an image. Not only did it fit but I've got like 4MB free. That's crazy.

More people should know about this fantastic service you guys have made.

1 Like

Awesome. Glad that helped!

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.