[Solved] Installation of lua-app-cshark

Hello
I'm using OpenWrt 23.05.3
on a D-Team Newifi D2.
That's a MediaTek MT7621 architecture with platform ramips/mt7621.

I'm pretty much of a noob to this so my settings are really basic but at this point it's working OK.

However I would like to do some packet capture from one of the devices on the lan.
If I understand correctly the tool that would do this is lua-app-cshark.

Unfortunately I'm not able to find it here.
...
Ehh Is this normal?
Is there some other place I must look and configure my openwrt device to look there?
Am I supposed to compile it myself? (Is there a cross procedure from an amd64 architecture?)

Any advice welcome

You don't need cshark necessarily. tcpdump can do the job and then you can either read the output on the router by SSH or copy the file on your PC and open it with wireshark.
opkg update; opkg install tcpdump; tcpdump -i eth0 -vnn not port 22
or to store it
tcpdump -i eth0 -w /tmp/capture.pcap -s0 not port 22 then read with tcpdump -r /tmp/capture.pcap or copy the file to PC with SCP.
There is also option to run the tcpdump and pipe the output straight to your linux PC.

ssh root@openwrt.lan tcpdump -i eth1 -U -s0 -w - 'not port 22' | sudo wireshark -k -i -

1 Like

(assuming cloudshark's still around, I haven't checked)

it'll get you a nice web interface for browsing the captured data, for free, for a month.

the data captured however, is the same as when you do it the way @trendy described.

Thanks for your replies.
Indeed @trendy 's idea was the way to go.
I don't know what I had done wrong but a previous
opkg install tcpdump
had not worked
well I guess my indexes were not recent enough.
opkg update
and immediate
opkg install ...
did it fine.
Thanks again for the replies :+1: I think I will manage from here :slight_smile:

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.