[SOLVED] Install Openwrt on Linksys mr8300

Hello, I just bought and installed the Linksys MR8300 V 1.1 router, I downloaded from openwrt the firmware for my router.... but how do I update the fimware of the router? I can not find any "Update" or Upload etc etc someone can tell me how I could do? I put the .bin file on a usb, and reboot it? Should I do a factory reset? Please help me
Thank you very much
ps excuse my speling mistakes but I use a google traslate

All of the following comes from several posts on this forum, with some additional details that took me some time to get right. The following worked for me:

You will need an admin password for the LinkSys firmware. I don't remember for sure if the password or recovery key on a sticker on the router will serve, or just "admin", but in any case you can set it in the LinkSys webapp. Not sure it can be set from the mobile app.

  • Go to 192.168.1.1 in a browser
  • click the picture (this will not appear as a link, but it is). In this way you can bypass having to use the mobile app.
  • Under connectivity > basic you can set the admin password.

Now you are ready to install OpenWrt:

  • NOTE: Don't ever perform a sysupdate: this replaces the OEM backup partition! Instead, boot into the original OEM firmware, then load OpenWrt factory distribution.
  • Disconnect from internet
  • Power cycle the router. The LED will blink red. You must be in the stock FW now, not an already installed OpenWrt, otherwise you will permanently remove the stock fallback.
  • Upload firmware at http://192.168.1.1/fwupdate.html. To enter, use the username "admin" and the password set in the LinkSys web application. After a factory reset use admin/admin.
  • The firmware will upload quite quickly and the router will reboot, blinking blue. Wifi will not work yet, and no password will be set yet. It will be listening on 192.168.1.1.

This router has two firmware partitions. When booting fails three times in a row, it automatically switches to the other firmware. When you are in OpenWrt and you want to boot into the other partition, enter into a terminal using ssh:

fw_printenv boot_part

this will show the present partition, which can be 1 or 2. Assuming it is 1, we want to reboot into 2:

fw_setenv boot_part 2

After rebooting, you will now go to the other partition, probably you'll want that to be the stock firmware.

From the stock firmware there is not such a direct way, so what you can do is force the boot process to fail three times in a row:

  1. Switch On and wait 15 seconds
  2. Switch Off and wait 10 seconds
  3. Repeat steps 1 and 2, three times, then go to 4.
  4. U-boot will switch to booting the previous working firmware - you should be able to access your router on LAN.

I keep a stopwatch handy and follow these time (approximately). So far it always worked at the first try.

luci-app-advanced-reboot would be a slightly more elegant (webif) based way to accomplish this.

3 Likes

Good point, thanks

Ok thank you very much

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.