[Solved] Install on PC Engines Wrap

Hi,

after working with Openwrt I tried to install LEDE on a Wrap. First Problem, the Image didn´t fit on a 256MB CF, before I used a 64MB one. Second Problem, it didn´t boot. I did make a Test in a VM with different Memory-Sizes: 512MB no boot, 1GB successfull boot. Remeber, a Wrap has 128Mb.

Regards,

jsffm

To be clear...what's a Wrap?

The uncompressed v17.01.4 image is 285.7 MB...this is greater then 256 MB. This isn't a problem, your CF card isn't large enough.

Well...I last created an 17.01.4 x86 machine in VM to test config and boot for another thread...it booted successfully with 256 MB...I suggest setting up a working virtual HDD and system config, first.

This is a Wrap: https://openwrt.org/toh/pcengines/wrap

I tried the generic Version, why needs this so much memory?

OK

I also used the Generic Version. I just tested booting 128 MB of RAM, it worked!

Can you explan this? Must I assemble my own image?

Sure.

  • You need a larger CF card, the image is 285.7 MB.
  • Perhaps, the memory is corrupted, check your memory.

The computer works fine for years without any memory problems

Topic updated accordingly.

1 Like
root@LEDE:/# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root               252.0M     10.2M    236.6M   4% /
tmpfs                   502.5M      1.1M    501.4M   0% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev

why do I need such a big CF for this small system?

But this is not really important, more imprtant is the memory problem

user@desktop:~/Downloads$ gzip -l lede-17.01.4-x86-generic-combined-ext4.img.gz
compressed uncompressed ratio uncompressed_name
7279860 285736960 97.5% lede-17.01.4-x86-generic-combined-ext4.img

Again, the image is 285.7 MB. If you wish to resize it, you can do so with tools such as GParted.

To store a filesystem with 10.2 Mb ...

But as I told before, this is a minor problem, the real problem is the memory

Again, it boots with 128 MB...Also, I just tested with 64 MB, it works too!

What error do you receive???

Have you tested the memory, though?

The problem is on two computers, the wrap, and the host for the vm, I can try the vm at an other host or check the memory on the host with memtest, but I´m sure I will get the same result.

@jsffm...

  • your OP is about the Wrap... you need a larger CF card, or to resize the image yourself.
  • regarding the VM, consider making a new thread, as the x86 image works with: 256, 128 and 64 MB RAM.

I always tested the image with an 2G CF, so as I told before, this is a minor problem

Consider marking this thread "SOLVED."

The memory is still my problem

The Wrap issue is SOLVED. Consider making a new thread for memory issues on the VM.

this means, the test on the wrap was negative, like in the vm.
I can´t change the memory on the wrap.

@jsffm...I 100% understand, as I've said mutiple times: