[Solved] Install latest version of nano that supports syntax highlighting


I have a device running OpenWRT v19.07.8 and it has nano v5.8 installed.

I am trying to install a newer version on it so ill have syntax highlighting. Is it possible to install a newer version of the package while I am on this version?

 cat /etc/openwrt_release 
DISTRIB_DESCRIPTION='OpenWrt 19.07.8 r11364-ef56c85848'

I have tried to pull a newer version of nano-full using wget from https://downloads.openwrt.org/releases/19.07.8/packages/x86_64/packages/ but when I try to install I get:

Unknown package 'nano-full'.
Collected errors:
 * pkg_hash_fetch_best_installation_candidate: Packages for nano-full found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package nano-full.

I would like to upgrade to a newer version but this device I have is a GL iNet product which only supports upto v19.7.8 with their also installed.

cat /etc/opkg/distfeeds.conf 
src/gz glinet_packages https://fw.gl-inet.com/releases/v19.07.8/packages-3.0/ath79/packages
src/gz glinet_private https://fw.gl-inet.com/releases/v19.07.8/packages-3.0/ath79/glinet
src/gz glinet_kmod https://fw.gl-inet.com/releases/v19.07.8/kmod-3.0/ath79/nand


It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

Did you talk to gl.inet? It's their firmware and their repositories.


The normal OpenWrt 19.07 actually has nano-full since March 2022, but like slh says, you are apparently using a third-party variant (made by gl-inet) that differs from the normal OpenWrt and uses their download repo.

You might succeed is downloading the package .ipk manually from OpenWrt download repo, and then installing it manually with opkg. But very likely gl-inet has uses slightly different versions of musl C lib, ncurses etc., so that the binary can be incompatible.


Thank you for the quick response on this!

I found my issue to be that I was using the wrong package for my architecture.

I pulled the package from the wrong URL on OpenWRT.

I needed the package from here and it worked with no issues: https://downloads.openwrt.org/releases/19.07.8/packages/mips_24kc/packages/nano-full_6.2-1_mips_24kc.ipk


Away from my other comment, yes, you are correct, and I apologise. I went about this backwards. I should have started with GL.iNet support on this before opening the thread here, but I do appreciate the feedback from you and hnyman.

I am happy for your comment to be the solution answer here.

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.