[Solved] I think I bricked my Ubiquiti EdgeRouter X SFP, please help

Hello. My EdgeRouter just arrived.

I tried to install OpenWRT on it, following https://openwrt.org/toh/ubiquiti/ubiquiti_edgerouter_x_er-x_ka#factory_firmware_installation_method using port eth0. File openwrt-18.06.4-ramips-mt7621-ubnt-erx-sfp-initramfs-kernel.bin. But I was getting error Checking upgrade image...Upgrade image does not support the device. Upgrade failed.

Googling about it, I found 2 people claiming to have solved it using a german factory image:


I tried it with no much hope, when I got success message exactly as in the tutorial (Upgrade completed). As I remember, show system image reported v1.7.1.

I used the reboot command and confirmed.

But it didn't come back. Ping kept reporting unreachable. I moved then to eth1 and then pinged successful, but now Putty reports error "Couldn't agree a client-to-server cipher (available: aes128-ctr, aes256-ctr)". Browser says can't establish a connection to the server.

I tried removing power cord, waited, same result.

Could somebody suggest what happened? Can it be saved? I'm very frustrated, but I think I was assuming the risk :confused:

Ok false alert e.e

My laptop's putty was outdated. I updated it and now it's working. I was even able to change its IP and plug it on my LAN, so now I'm accessing my router directly from PC.

I'm now trying to properly install OpenWRT on it. That german image doesn't have luci, so I can't use it to upgrade.

Obvious attempt is to upgrade it. I try sysupgrade openwrt-18.06.4-ramips-mt7621-ubnt-erx-sfp-squashfs-sysupgrade.tar but I get an odd error:

root@OpenWrt:/tmp# sysupgrade openwrt-18.06.4-ramips-mt7621-ubnt-erx-sfp-squashfs-sysupgrade.tar
Device ubnt-erx not supported by this image
Supported devices: ubnt-erx-sfp
Image check 'fwtool_check_image' failed.

What I understand from this message is that "the image" is recognizing the device as a ubnt-erx, not a ubnt-erx-sfp... but it is a sfp! I see the SFP port on the left of its 5 normal RJ45 ports!

Ok, trying to install luci then. I ran opkg update then install luci, here's the full output:

root@OpenWrt:/tmp# opkg update
Downloading http://downloads.lede-project.org/snapshots/targets/ramips/mt7621/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/%n_core
Downloading http://downloads.lede-project.org/snapshots/targets/ramips/mt7621/packages/Packages.sig
Signature check passed.
Downloading http://downloads.lede-project.org/snapshots/packages/mipsel_24kc/base/Packages.gz
Updated list of available packages in /var/opkg-lists/%n_base
Downloading http://downloads.lede-project.org/snapshots/packages/mipsel_24kc/base/Packages.sig
Signature check passed.
Downloading http://downloads.lede-project.org/snapshots/packages/mipsel_24kc/luci/Packages.gz
Updated list of available packages in /var/opkg-lists/%n_luci
Downloading http://downloads.lede-project.org/snapshots/packages/mipsel_24kc/luci/Packages.sig
Signature check passed.
Downloading http://downloads.lede-project.org/snapshots/packages/mipsel_24kc/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/%n_packages
Downloading http://downloads.lede-project.org/snapshots/packages/mipsel_24kc/packages/Packages.sig
Signature check passed.
Downloading http://downloads.lede-project.org/snapshots/packages/mipsel_24kc/routing/Packages.gz
Updated list of available packages in /var/opkg-lists/%n_routing
Downloading http://downloads.lede-project.org/snapshots/packages/mipsel_24kc/routing/Packages.sig
Signature check passed.
Downloading http://downloads.lede-project.org/snapshots/packages/mipsel_24kc/telephony/Packages.gz
Updated list of available packages in /var/opkg-lists/%n_telephony
Downloading http://downloads.lede-project.org/snapshots/packages/mipsel_24kc/telephony/Packages.sig
Signature check passed.
root@OpenWrt:/tmp# opkg install luci
Installing luci (git-19.243.51105-2fab0ad-1) to root...
Collected errors:
 * verify_pkg_installable: Only have 0kb available on filesystem /overlay, pkg luci needs 1
 * opkg_install_cmd: Cannot install package luci.

https://forum.archive.openwrt.org/viewtopic.php?id=31353 I found

Yes, squashfs is read-only, so nothing gets removed (and trying to remove some modules will just consume more space, as you already noticed).
You probably need to build an own image.

I don't know what squashfs means, but looks like this image is no good.

What should I do now? Is it possible to reinstall openwrt-18.06.4-ramips-mt7621-ubnt-erx-sfp-initramfs-kernel.bin now that I'm free from EdgeOS?

Or should I sysupgrade to a ubnt-erx (no sfp) sysupgrade.tar?

The German firmware you installed is likely built for non SFP. You can check this with cat /proc/cpuinfo.

It is probably safe to force an upgrade between the two.

1 Like

Indeed! Russell on IRC helped me! I did sysupgrade -F on the correct sysupgrade.tar and it worked. After reboot I had the correct version! \o/

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.