[Solved] I think I bricked my ea 4500 and I don’t know how. Help!

Well I tried flashing my linksys EA4500 router with lede today. I followed the right guides here on the site and everything worked out well. I installed it and continued with the guide setting it up. I got to the point where it said to connect it to the isp router/modem to check for internet connection. So I unplugged it and brought it upstairs with the laptop to plug it in to the isp box. There wasn’t any internet connection, so I figured I’d restart my laptop and the newly flashed lede box and try again. Voila! I’ve got internet. So then I try and log in to the router Can’t connect so I fiddle with it for a while unplugging it, letting it sit, trying over and over. Nothin! Finally I decide to check the default gateway using ip config/all, but it’s blank. Everything else seems to be there, but next to default gateway there’s nothin! I don’t know how this happened. Like I said I was already in there to set it up to that point. It either had to do with the unplugging, or connecting it to the isp box. Anyway then I thought I’d reset it back to the previous version using the reset button on the back. But the reset button doesn’t do anything now. No flashing lights, noises, nothin! Hopefully one of you more experienced guys will know at least what might have happened. Even if it’s ruined I’d like to know what happened. Thanks for any replies.

First, read the section in the LEDE documentation on Failsafe Mode and Factory Reset...


If that works, you might look over the LEDE User Guide on how to set up and configure LEDE...


Well I’ve been trying for hours to get into failsafe mode with no luck. There are two buttons on my router. Wps and reset and I’ve tried them both extensively with no luck. I also downloaded wire shark and it’s not showing me the failsafe entry either. I’m not sure if wireshark is the right one but maybe you could steer me in the right direction? Thanks

Your EA4500 has two boot partitions.

One would contain the original Linksys firmware, and the other LEDE (unless you flashed both partitions with LEDE).

Try this technique for booting to a different parition, and hopefully get you back to stock firmware...


Yep it did. I found that earlier today on my own. Thanks though. No I have a new problem I’m trying to set up pia on this lede router and somethings not right. This is what I posted on the private internet access sub Reddit just a few min ago.

I’m following this guide


Everything was working until I got to this step

Now, we need to format the credentials file. *If you are on Linux or Mac you can skip the following 8 steps

I’m on Windows 10 so I did as it said. But In putty it said.

-Ash: can’t open /etc/OpenVPN/credentials.txt: no such file

Seeing as I’m only following a guide and without it I have no idea what to do. I really need someone to tell me what’s gone wrong.


Edit: I just went back to try everything again. And in the previous step where it tells me to type into cmd (not putty) I get this message. I must not have noticed it before.

Pscp: remote filespec /etc/OpenVPN: not a directory

Now I never created a directory, but I think the previous steps were supposed to create that directory. Unless I’m wrong.

Something else I noticed that might have been the culprit was that on the pia site the files to download were followed by .crt when I look under the properties of the files on my computer once they’re downloaded it says .cer. Is that because I’m in Windows 10 and the guide is a bit older , or would explain it? If so how do I fix it? Thanks for all your help.

OpenVPN was supposed to be installed in SECTION 3: ROUTER UPDATES, which would have created the openvpn directory.

Credentials.txt was supposed to be copied over to /etc/openvpn/ in SECTION 4: UPLOAD CREDENTIALS AND CERTIFICATES

Looks like you missed a few steps.

I did the router updates. Just so I know should there be an entry saying open vpn package when I do the router updates? Cause I looked and it wasn’t there.

I just logged into the router through the browser and it shows that open vpn is there under services. Why would it say not a directory? Thanks

So according to the PIA tutorial, two packages should have been installed...


in LuCI, click on the System tab and select Software. Scroll down, and you should see those two packages (if they were installed) in the Installed packages list.

If they are not installed, click on the Update lists button at the top to refresh the list (which is the same thing that was supposed to happen using SSH).

Once the list is updated, do a search by entering the package name in the Filter box and click on Find package. The results will show in the Available packages list (I was able to find both packages).

From there, simply click on the Install link.

You might download and run WinSCP.


It will give you a windows-like view of the router directory tree, along with other functions such as copy from a PC to the router, search, etc.

Ok I did as you said and checked in LuCI, they're both there. So then I downloaded winscp and connected to the router. I'm not really sure where to look, but the PIA directory was

pscp Documents/PIA_Setup/* root@

so I cecked in /etc. it wasn't right there, but digging a little further into /etc/config there were two. openvpn_recipes and just openvpn. Does this mean I should edit "/etc/openvpn" to "/etc/config/openvpn"?

Thanks again

I just tried by adding config. it still says not a directory. any ideas?

I would start from scratch...to confirm that you did not miss anything.

Failing that, and since these are PIA's instructions, I would contact their support.


well I did start from scratch, and now when I check only openvpn_recipes is there now. In LuCI they're both still there though. Thanks and I will contact PIA.

New threaded started here...

Since this topic is marked as solved, and since there is already a new thread, I'm going to close this one.