[SOLVED]I can't put two guest wifi on the same interface

Hi.
I'm trying to put two guest networks on the same interface, the first network works (wlan0-2), but the second one (wlan0-3) keeps looking for ip and doesn't even connect

My configuration is this

/etc/config/network

config interface 'testea'                                                                                                              
        option proto 'static'                                                                                                          
        option ipaddr '10.10.9.1'                                                                                                      
        option netmask '255.255.255.0'

/etc/config/wireless

config wifi-iface 'wifinet3'                                                                                                           
        option device 'radio0'                                                                                                         
        option mode 'ap'                                                                                                               
        option ssid 'testG'                                                                                                            
        option encryption 'none'                                                                                                       
        option network 'testea'                                                                                                        
                                                                                                                                       
config wifi-iface 'wifinet4'                                                                                                           
        option device 'radio0'                                                                                                         
        option mode 'ap'                                                                                                               
        option ssid 'testG2'                                                                                                           
        option encryption 'none'                                                                                                       
        option network 'testea'

/etc/config/dhcp

config dhcp 'testea'                                                                                                                   
        option interface 'testea'                                                                                                      
        option start '100'                                                                                                             
        option limit '150'                                                                                                             
        option leasetime '12h'

/etc/config/firewall

config zone                                                                                                                            
        option name 'wifi2t'                                                                                                           
        option input 'ACCEPT'                                                                                                          
        option output 'ACCEPT'                                                                                                         
        option forward 'REJECT'                                                                                                        
        list network 'testea'                                                                                                          
                                                                                                                                       
config forwarding                                                                                                                      
        option src 'wifi2t'                                                                                                            
        option dest 'wan'                                                                                                              
                                                                                                                                       
config rule                                                                                                                            
        option name 'dns'                                                                                                              
        option src 'wifi2t'                                                                                                            
        option dest_port '53'                                                                                                          
        option target 'ACCEPT'                                                                                                         
                                                                                                                                       
config rule                                                                                                                            
        option name 'dhco'                                                                                                             
        list proto 'udp'                                                                                                               
        option src 'wifi2t'                                                                                                            
        option dest_port '67'                                                                                                          
        option target 'ACCEPT'
1 Like

Please also give the router model (and target) and your complete wifi config file. I can't tell if I will be able to help you, but others users will need these infos to answer you. Some devices may have specific issues with wifi.

1 Like

Also an iw list , there might be a limitation on the driver.

2 Likes

D-LInk DIR-878 A1

config wifi-device 'radio0'                                                                                                            
        option type 'mac80211'                                                                                                         
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'                                                               
        option band '2g'                                                                                                               
        option cell_density '0'                                                                                                        
        option country 'VE'                                                                                                            
        option channel '11'                                                                                                            
        option htmode 'HT20'                                                                                                           
                                                                                                                                       
config wifi-iface 'default_radio0'                                                                                                     
        option device 'radio0'                                                                                                         
        option network 'lan'                                                                                                           
        option mode 'ap'                                                                                                               
        option ssid 'G WIFI'                                                                                                           
        option key '1XXXXXXXX'                                                                                                       
        option dtim_period '3'                                                                                                         
        option maxassoc '12'                                                                                                           
        option encryption 'psk2'

config wifi-device 'radio1'                                                                                                            
        option type 'mac80211'                                                                                                         
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'                                                               
        option band '5g'                                                                                                               
        option htmode 'VHT80'                                                                                                          
        option channel '48'                                                                                                            
        option txpower '14'                                                                                                            
        option country 'BR'                                                                                                            
        option cell_density '0'                                                                                                        
                                                                                                                                       
config wifi-iface 'default_radio1'                                                                                                     
        option device 'radio1'                                                                                                         
        option network 'lan'                                                                                                           
        option mode 'ap'                                                                                                               
        option ssid 'G WIFI 5G'                                                                                                        
        option key 'XXXXXXXX'                                                                                                       
        option hidden '1'                                                                                                              
        option dtim_period '3'                                                                                                         
        option maxassoc '4'                                                                                                            
        option encryption 'psk2'

config wifi-iface 'wifinet2'                                                                                                           
        option device 'radio0'                                                                                                         
        option mode 'ap'                                                                                                               
        option key XXXXXX'                                                                                                        
        option ssid 'G WIFI-guest'                                                                                                     
        option network 'guest'                                                                                                         
        option isolate '1'                                                                                                             
        option encryption 'psk2'

config wifi-iface 'wifinet3'                                                                                                           
        option device 'radio0'                                                                                                         
        option mode 'ap'                                                                                                               
        option ssid 'testG'                                                                                                            
        option encryption 'none'                                                                                                       
        option network 'testea'                                                                                                        
                                                                                                                                       
config wifi-iface 'wifinet4'                                                                                                           
        option device 'radio0'                                                                                                         
        option mode 'ap'                                                                                                               
        option ssid 'testG2'                                                                                                           
        option encryption 'none'                                                                                                       
        option network 'testea'
Wiphy phy1                                                                                                                             
        wiphy index: 1                                                                                                                 
        max # scan SSIDs: 4                                                                                                            
        max scan IEs length: 2304 bytes                                                                                                
        max # sched scan SSIDs: 0                                                                                                      
        max # match sets: 0                                                                                                            
        Retry short limit: 7                                                                                                           
        Retry long limit: 4                                                                                                            
        Coverage class: 0 (up to 0m)                                                                                                   
        Device supports AP-side u-APSD.                                                                                                
        Device supports T-DLS.                                                                                                         
        Available Antennas: TX 0xf RX 0xf                                                                                              
        Configured Antennas: TX 0xf RX 0xf                                                                                             
        Supported interface modes:                                                                                                     
                 * IBSS                                                                                                                
                 * managed                                                                                                             
                 * AP                                                                                                                  
                 * AP/VLAN                                                                                                             
                 * monitor                                                                                                             
                 * mesh point                                                                                                          
                 * P2P-client                                                                                                          
                 * P2P-GO                                                                                                              
        Band 2:                                                                                                                        
                Capabilities: 0x1ff                                                                                                    
                        RX LDPC                                                                                                        
                        HT20/HT40                                                                                                      
                        SM Power Save disabled                                                                                         
                        RX Greenfield                                                                                                  
                        RX HT20 SGI                                                                                                    
                        RX HT40 SGI                                                                                                    
                        TX STBC                                                                                                        
                        RX STBC 1-stream                                                                                               
                        Max AMSDU length: 3839 bytes                                                                                   
                        No DSSS/CCK HT40                                                                                               
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)                                                                  
                Minimum RX AMPDU time spacing: No restriction (0x00)                                                                   
                HT TX/RX MCS rate indexes supported: 0-31                                                                              
                VHT Capabilities (0x338001f8):                                                                                         
                        Max MPDU length: 3895                                                                                          
                        Supported Channel Width: 160 MHz, 80+80 MHz                                                                    
                        RX LDPC                                                                                                        
                        short GI (80 MHz)                                                                                              
                        short GI (160/80+80 MHz)                                                                                       
                        TX STBC                                                                                                        
                        RX antenna pattern consistency                                                                                 
                        TX antenna pattern consistency                                                                                 
                VHT RX MCS set:                                                                                                        
                        1 streams: MCS 0-9                                                                                             
                        2 streams: MCS 0-9                                                                                             
                        3 streams: MCS 0-9                                                                                             
                        4 streams: MCS 0-9                                                                                             
                        5 streams: not supported                                                                                       
                        6 streams: not supported                                                                                       
                        7 streams: not supported                                                                                       
                        8 streams: not supported                                                                                       
                VHT RX highest supported: 0 Mbps                                                                                       
                VHT TX MCS set:                                                                                                        
                        1 streams: MCS 0-9                                                                                             
                        2 streams: MCS 0-9                                                                                             
                        3 streams: MCS 0-9                                                                                             
                        4 streams: MCS 0-9                                                                                             
                        5 streams: not supported                                                                                       
                        6 streams: not supported                                                                                       
                        7 streams: not supported                                                                                       
                        8 streams: not supported                                                                                       
                VHT TX highest supported: 0 Mbps                                                                                       
                Frequencies:                                                                                                           
                        * 5180 MHz [36] (23.0 dBm)                                                                                     
                        * 5200 MHz [40] (23.0 dBm)                                                                                     
                        * 5220 MHz [44] (23.0 dBm)                                                                                     
                        * 5240 MHz [48] (23.0 dBm)                                                                                     
                        * 5260 MHz [52] (23.0 dBm) (radar detection)                                                                   
                        * 5280 MHz [56] (23.0 dBm) (radar detection)                                                                   
                        * 5300 MHz [60] (23.0 dBm) (radar detection)                                                                   
                        * 5320 MHz [64] (23.0 dBm) (radar detection)                                                                   
                        * 5500 MHz [100] (disabled)                                                                                    
                        * 5520 MHz [104] (disabled)                                                                                    
                        * 5540 MHz [108] (disabled)                                                                                    
                        * 5560 MHz [112] (disabled)                                                                                    
                        * 5580 MHz [116] (disabled)                                                                                    
                        * 5600 MHz [120] (disabled)                                                                                    
                        * 5620 MHz [124] (disabled)                                                                                    
                        * 5640 MHz [128] (disabled)                                                                                    
                        * 5660 MHz [132] (disabled)                                                                                    
                        * 5680 MHz [136] (disabled)                                                                                    
                        * 5700 MHz [140] (disabled)                                                                                    
                        * 5720 MHz [144] (disabled)                                                                                    
                        * 5745 MHz [149] (29.0 dBm)                                                                                    
                        * 5765 MHz [153] (29.0 dBm)                                                                                    
                        * 5785 MHz [157] (29.0 dBm)                                                                                    
                        * 5805 MHz [161] (29.0 dBm)                                                                                    
                        * 5825 MHz [165] (29.0 dBm)                                                                                    
                        * 5845 MHz [169] (disabled)                                                                                    
                        * 5865 MHz [173] (disabled)                                                                                    
        valid interface combinations:                                                                                                  
                 * #{ IBSS } <= 1, #{ managed, AP, mesh point, P2P-client, P2P-GO } <= 16,                                             
                   total <= 16, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz, 80
+80 MHz, 160 MHz }                                                                                                                     
                                                                                                                                       
        HT Capability overrides:                                                                                                       
                 * MCS: ff ff ff ff ff ff ff ff ff ff                                                                                  
                 * maximum A-MSDU length                                                                                               
                 * supported channel width                                                                                             
                 * short GI for 40 MHz                                                                                                 
                 * max A-MPDU length exponent                                                                                          
                 * min MPDU start spacing                                                                                              
        max # scan plans: 1                                                                                                            
        max scan plan interval: 0                                                                                                      
        max scan plan iterations: 0                                                                                                    
        Supported extended features:                                                                                                   
                * [ VHT_IBSS ]: VHT-IBSS                                                                                               
                * [ RRM ]: RRM                                                                                                         
                * [ SET_SCAN_DWELL ]: scan dwell setting                                                                               
                * [ FILS_STA ]: STA FILS (Fast Initial Link Setup)                                                                     
                * [ CQM_RSSI_LIST ]: multiple CQM_RSSI_THOLD records                                                                   
                * [ CONTROL_PORT_OVER_NL80211 ]: control port over nl80211                                                             
                * [ TXQS ]: FQ-CoDel-enabled intermediate TXQs                                                                         
                * [ AIRTIME_FAIRNESS ]: airtime fairness scheduling                                                                    
                * [ AQL ]: Airtime Queue Limits (AQL)                                                                                  
                * [ CONTROL_PORT_NO_PREAUTH ]: disable pre-auth over nl80211 control port support                                      
                * [ DEL_IBSS_STA ]: deletion of IBSS station support                                                                   
                * [ SCAN_FREQ_KHZ ]: scan on kHz frequency support                                                                     
                * [ CONTROL_PORT_OVER_NL80211_TX_STATUS ]: tx status for nl80211 control port support                                  
Wiphy phy0                                                                                                                             
        wiphy index: 0                                                                                                                 
        max # scan SSIDs: 4                                                                                                            
        max scan IEs length: 2304 bytes                                                                                                
        max # sched scan SSIDs: 0                                                                                                      
        max # match sets: 0                                                                                                            
        Retry short limit: 7                                                                                                           
        Retry long limit: 4                                                                                                            
        Coverage class: 0 (up to 0m)                                                                                                   
        Device supports AP-side u-APSD.                                                                                                
        Device supports T-DLS.                                                                                                         
        Available Antennas: TX 0xf RX 0xf                                                                                              
        Configured Antennas: TX 0xf RX 0xf                                                                                             
        Supported interface modes:                                                                                                     
                 * IBSS                                                                                                                
                 * managed                                                                                                             
                 * AP                                                                                                                  
                 * AP/VLAN                                                                                                             
                 * monitor                                                                                                             
                 * mesh point                                                                                                          
                 * P2P-client                                                                                                          
                 * P2P-GO                                                                                                              
        Band 1:                                                                                                                        
                Capabilities: 0x1ff                                                                                                    
                        RX LDPC                                                                                                        
                        HT20/HT40                                                                                                      
                        SM Power Save disabled                                                                                         
                        RX Greenfield                                                                                                  
                        RX HT20 SGI                                                                                                    
                        RX HT40 SGI                                                                                                    
                        TX STBC                                                                                                        
                        RX STBC 1-stream                                                                                               
                        Max AMSDU length: 3839 bytes                                                                                   
                        No DSSS/CCK HT40                                                                                               
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)                                                                  
                Minimum RX AMPDU time spacing: No restriction (0x00)                                                                   
                HT TX/RX MCS rate indexes supported: 0-31                                                                              
                Frequencies:                                                                                                           
                        * 2412 MHz [1] (28.0 dBm)                                                                                      
                        * 2417 MHz [2] (28.0 dBm)                                                                                      
                        * 2422 MHz [3] (28.0 dBm)                                                                                      
                        * 2427 MHz [4] (28.0 dBm)                                                                                      
                        * 2432 MHz [5] (28.0 dBm)                                                                                      
                        * 2437 MHz [6] (28.0 dBm)                                                                                      
                        * 2442 MHz [7] (28.0 dBm)                                                                                      
                        * 2447 MHz [8] (28.0 dBm)                                                                                      
                        * 2452 MHz [9] (28.0 dBm)                                                                                      
                        * 2457 MHz [10] (28.0 dBm)                                                                                     
                        * 2462 MHz [11] (28.0 dBm)                                                                                     
                        * 2467 MHz [12] (28.0 dBm)                                                                                     
                        * 2472 MHz [13] (28.0 dBm)                                                                                     
                        * 2484 MHz [14] (disabled)                                                                                     
        valid interface combinations:                                                                                                  
                 * #{ IBSS } <= 1, #{ managed, AP, mesh point, P2P-client, P2P-GO } <= 16,                                             
                   total <= 16, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz, 80
+80 MHz, 160 MHz }                                                                                                                     
                                                                                                                                       
        HT Capability overrides:                                                                                                       
                 * MCS: ff ff ff ff ff ff ff ff ff ff                                                                                  
                 * maximum A-MSDU length                                                                                               
                 * supported channel width                                                                                             
                 * short GI for 40 MHz                                                                                                 
                 * max A-MPDU length exponent                                                                                          
                 * min MPDU start spacing                                                                                              
        max # scan plans: 1                                                                                                            
        max scan plan interval: 0                                                                                                      
        max scan plan iterations: 0                                                                                                    
        Supported extended features:                                                                                                   
                * [ VHT_IBSS ]: VHT-IBSS                                                                                               
                * [ RRM ]: RRM                                                                                                         
                * [ SET_SCAN_DWELL ]: scan dwell setting                                                                               
                * [ FILS_STA ]: STA FILS (Fast Initial Link Setup)                                                                     
                * [ CQM_RSSI_LIST ]: multiple CQM_RSSI_THOLD records                                                                   
                * [ CONTROL_PORT_OVER_NL80211 ]: control port over nl80211                                                             
                * [ TXQS ]: FQ-CoDel-enabled intermediate TXQs                                                                         
                * [ AIRTIME_FAIRNESS ]: airtime fairness scheduling                                                                    
                * [ AQL ]: Airtime Queue Limits (AQL)                                                                                  
                * [ CONTROL_PORT_NO_PREAUTH ]: disable pre-auth over nl80211 control port support                                      
                * [ DEL_IBSS_STA ]: deletion of IBSS station support                                                                   
                * [ SCAN_FREQ_KHZ ]: scan on kHz frequency support                                                                     
                * [ CONTROL_PORT_OVER_NL80211_TX_STATUS ]: tx status for nl80211 control port support

Could you try to delete one of the other interfaces and verify that the 2 new ones both work?
I am under the impression that you have hit a limit of 4 interfaces.

1 Like

That should not solve your issue, but put the same country in both interfaces. You seem to live somewhere between Brazil and Venezuela ?
I have made test with R6220 (mt7621 with latest snapshot). On the radio1 (5Ghz), I have set 2 AP, one with key password, one without, and I ran in the issue than you: device can't get an IP.

I live in Brazil, is it a country problem, I'm going through BR

I put the two networks (wlan0-2 and wlan0-3) 2 connects and 3 is trying to find IP

The problem here is that testea is not a bridge. A non-bridge interface can only have one physical device. For dual-band wifi or wifi plus Ethernet, make a bridge br-testea along the same principle as the default br-lan.

3 Likes

I made the bridge and grouped the networks, but now none of them can get ip so is looking for ip

Please share updated config files.

/etc/config/network

config interface 'testA'                                                                                                               
        option proto 'static'                                                                                                          
        option ipaddr '10.10.9.1'                                                                                                      
        option netmask '255.255.255.0'                                                                                                 
        option device 'br-testeA'                                                                                                      
        option type 'bridge'                                                                                                           
                                                                                                                                       
config device                                                                                                                          
        option type 'bridge'                                                                                                           
        option name 'br-testeA'

/etc/config/wireless

config wifi-iface 'wifinet3'                                                                                                           
        option device 'radio0'                                                                                                         
        option mode 'ap'                                                                                                               
        option ssid 'testGG'                                                                                                           
        option network 'testA'                                                                                                         
        option encryption 'psk2'                                                                                                       
        option key '12345678'

/etc/config/dhcp

config dhcp 'testA'                                                                                                                    
        option interface 'testA'                                                                                                       
        option start '100'                                                                                                             
        option limit '150'                                                                                                             
        option leasetime '12h'

That is wrong. option type bridge in an interface section is the deprecated old syntax, and can't be combined with the new standard of separately declared bridges.

Also don't use uppercase in network names. By convention the bridge has the same name as the interface except for adding br- at the front. I don't know if not following that convention works or not.

1 Like

I'm using the latest build snapshot the GUI LuCI to create the settings

I recreated the settings and the network worked

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.