[Solved] HTTPS Error Timeout

I cannot access https, follwed this guide https://fabianlee.org/2016/09/19/openwrt-enabling-https-for-the-luci-web-admin-interface/

Does the same happen when you follow https://openwrt.org/docs/guide-user/luci/luci.essentials#providing_encryption ?

That's what is saying when installing it,

Use opkg install luci-ssl instead of luci-ssl-openssl.

You are getting conflicts, luci-ssl-openssl is trying to install an ssl library which is already installed by mbedtls (maybe even by default? I'm not sure). mbedtls is the default SSL/TLS library for OpenWrt now, the instructions may be outdated.

Same problem after installing package, on chrome says the same but on internet explorer its this

Where are you getting port 4076 from? HTTPS by default runs on port 443, which you would not even have to state if you prefix the url with "https://".

Port 4076 is from uhttpd, this is what i get with 443,

Eek. I just noticed you set both http and https to the same port. That, I believe, will not work. You should choose a different port for https.

1 Like

let me change that right quick

worked thank, just needed a port change,

Have a nice day

You are very welcome, glad it worked out.

@manjotsc If your problem is solved, please consider marking the topic as [Solved] (Click the pencil behind the topic...).

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.