[Solved] How to recover NBG6817 after sysupgrade not holding configuration no web interface

Greetings, I need help how to get working my router NBG6817 again.
After I made sysupgrade from luci web interface and after rebooting the router I have no internet connection, no web interface.
When I manually edit /etc/config/network adding wan static settings the ping to my wan gateway not works, only can ping my routers wan ip and lan ip (
SSH is working, even can get into the recovery mode powering on and after blinking power led holding reset an release it after power led starts blinking fast.
When i tried again have made sysupgrade (scp binfile to routers /tmp folder) from routers CLI i have same results - not working inet even web interface.
tried flashing: 18.06.04 https://downloads.openwrt.org/releases/18.06.4/targets/ipq806x/generic/openwrt-18.06.4-ipq806x-zyxel_nbg6817-squashfs-sysupgrade.bin
and snapshot

in failsafe recovery mode when do I: mount_root I get:

failed to mount -t ext4 /dev/loop0 /tmp/overlay: No such device
overlay filesystem has not been fully initialized yet
switching to ext4 overlay
switching to ext4 failed - fallback to ramoverlay

root@(none):/rom/root# **df -h**                                                                                           Filesystem                Size      Used Available Use% Mounted on
/dev/root                 3.3M      3.3M         0 100% /rom/rom
tmpfs                   512.0K         0    512.0K   0% /dev
tmpfs                   234.6M     28.0K    234.6M   0% /tmp
tmpfs                   234.6M         0    234.6M   0% /tmp/root
overlayfs:/tmp/root     234.6M         0    234.6M   0% /rom
tmpfs                   234.6M         0    234.6M   0% /tmp/root
overlayfs:/tmp/root     234.6M         0    234.6M   0% /

ok it seems that I manged it out somehow,
first rebooted into alternative partiion: **Switch device power off. **
3x Switch device power on for 2 seconds, then off again.
Switch device power on, the device should now boot to the alternative partition.
ssh root@
after then from CLI:
vi /ec/config/network
and editing the wan setings with correct settings, brings on the internet and after then I CLI:
opkg install luci-base
opkg install lucissl-openssl
bring the web inerface on,will work on it and report later

seems that when I make configuration from luci web interface or CLI, and save it,after routers reboot, the config loses again

That behaviour is a bit strange… (don't see it on mine)

Judging from your description, the device wasn't really bricked - as you still had ssh access and could use sysupgrade; sysupgrade -n /tmp/*nbg6817*sysupgrade*.bin should have sorted it.

In case you really 'bricked' your device, push-button tftp will always help to recover your device (you can take either the OEM firmware or OpenWrt's factory images for recovering), see https://openwrt.org/toh/zyxel/nbg6817#debricking for details.

I would suggest to check dmesg and logread first, maybe you'll find the reasons for your issues.

I think the problems began when I played with upgrade from web interface, as I have two partitions, on one is
OpenWrt (Linux 4.14.131) stable release and on the second is OpenWrt (Linux 4.14.140) snapshot release,
somehow I overlooked on which I am booted and probably I was on the snapshot and tried upgrade some apps (I used web and even CLI: opkg install interface), which were not compatible with kernel (they should have kernel Linux 4.14.141) and there begun problems...
Never mind, it seems to working again all two partitions, I learned something new :smiley:
I found out when I am on the stable release my wifi leds blinking amber
and when I am on snapshot release my wifi leds are blinking white :smirk:

White is the correct colour, but support for ath10k controlled GPIOs only became available after 18.06 was branched off. Previous releases (including 18.06.x) 'abused' the amber LEDs instead, which were originally meant to report failure conditions, as those are directly accessible from the SOC.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.