Solved ! How to Reconfig WiFi in 18.06.2 ...?

Hello everbody, I need to reconfig my /etc/config/wireless file, so I searched, and found this:

rm -f /etc/config/wireless


wifi config

but its not working... the instructions above, I took from

has someone a Tipp please ? Im on a WRT 3200ACM with OpenWRT 18.06.2, the commad:
wifi config just dont work sadly....

It would help me maybe too, if some kind soul, could send me the file with factory I could create that file new, and paste in the code... from a /etc/config/wireless file that comes with OpenWRT after installing it new on a WRT 3200 ACM....

Thank you for reading, and help :wink:

I have a strange behavior in Network -> Wireless----

see picture please---

A rango wireless, LuCI will mess up if the file is corrupt, iirc wifi config will not do anything if a wireless config exists (even a zero length file).

Edit: should add that is from master, but I think the path is the same as of 18.x.

1 Like

I deleted it, and wanted to recreate it... ... Oh NO , must reset all my setup then again... Thanks for reply

Remove the file, then reboot.

If this does not build a new file, run iw list to see if your drivers are installed and detected the radios.

1 Like

Just did a reboot and typed in your command iw list, result:

{19-06-25 4:15}lede:~ root# iw list
nl80211 not found.
{19-06-25 4:15}lede:~ root#

Is this a new install of the new stable that is currently messed up.

1 Like

I deleted the file in /etc/config/wireless

reboootet, and now in Luci Webinterface ->Network, WIRELESS Menu is gone too...

Its a new installation... OpenWrt 18.06.2 r7676 on a WRT 3200 ACM

  • restore a backup
  • install again
  • power switch to the other partition if image is good
1 Like

OK, its my fault, I thought the instructions for recreating work

rm -f /etc/config/wireless


wifi config


Thank you anyways

nl80211 is part of the driver stack that should be there. Your basic install may be corrupted. Re-flash with 18.06.2. You can likely save settings.

1 Like

Thanks, its all fixed, I have reset all, without flashing new...and have setup all new, now all is fine, including RADIUS authentication to my Radius server un a Ubuntumachine, with wpad, wiregurad, privoxy, adblock, DNSCRYPT ...etc etc...took me 2h, but now all is fine again :star_struck:

1 Like

@MooMan If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)