[Solved] How to make a wifi connection to the WAN interface so I can mess around with the LAN interfaces

I am trying to establish a wireless connection so I can change the other interfaces. So far I can connect to the wireless but after less than a minute my laptop drops it and connects to my home wireless. I am thinking I need to activate the wifi interface and get an IP. What are the steps for this? I have been able to use this same device as an access point so I am not sure what I am doing wrong. FYI my experience with the openwrt community has been so positive. Thank you to everyone please. I don't know who is working on making the Banana PI R3 work but they are doing a good job.

Is this the device you're having an issue with?

Are you referring to the laptop or the OpenWrt device (as your preceeding sentence implies you connected to it already, albeit it disconnected you).

Can you connect via Ethernet cable?

1 Like

I got it working. I turned on the DHCP server and now it stays connected, also I set the firewall "policy" to LAN. I am not sure if that was necessary or not because I made the wifi interface point to the WAN.

Yes. It's the Banana PI R3. My laptop is set to dhcp client, it's Fedora 38 SilverBlue. Yes I am able to connect via an ethernet cable.

1 Like

All the configuration steps I was doing are in openwrt. My laptop is in dhcp client mode.

1 Like

Then in the OpenWrt web GUI, you'll browse to Network > Wireless and setup/enable WiFi.

1 Like

I think the difference is the ethernet connection had a dhcp server setup for it and the wifi didn't. Once either the openwrt router or the laptop "realized" there was no IP address on the wifi, it disconnected and switched to the wifi it was connected too.

Yes, that description sounded normal.

If you properly configure the WiFi - in most cases it just needs to be enabled and encryption set (e.g. WPA2 CCMP). By default the OpenWrt SSID is already configured for the same LAN as the Ethernet cable (i.e. LAN), so DHCP should be working after enabling it.

1 Like

You are right. I had an encryption key for wifi configured and wifi was tied to the lan interface by default. I needed it tied to the wan interface though so I can play with bridging / trunking on the lan interfaces. So when I connected the wifi to the wan interface then enabled the dhcp server for the wan interface it worked. I don't know if changing the firewall to point to the lan interface did anything.

1 Like

Usually the upstream device on WAN provides DHCP, and usually WiFi is on LAN. But cool - glad you got it working!

This statement is unclear. Usually WAN is in the WAN Firewall Zone - and respectively, LAN is in LAN.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

This statement is unclear. Usually WAN is in the WAN Firewall Zone - and respectively, LAN is in LAN.

So sorry for that. The reason I mentioned it is because I changed the wan interface to be in the lan firewall zone. Also I was saying I am not sure if that was part of the solution or not. I made the change because usually the wan firewall rules are more restrictive and I wanted them to be less restrictive. It makes me wonder what would happen if I set it to unspecified. Does that mean no firewall rules are applied? I need to do some discovery here.

The Global rules would apply - this is not suggested configuration.

  • Since you don't explain why you're moving WAN, it's not clear why you need its firewall to be less restrictive
  • You could also just edit the WAN Firewall settings
1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.