[Solved] How to I revert to Factory Image on WRT3200ACM

Why does SYSTEM/BACKUP/FLASH /Flash new firmware image not work with the factory image? I installed and tried out several different OS images for the WRT3200ACM router until I installed LEDE. This was a DEAD END. It will not allow the image to install. The error is "The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform." I cannot find where anyone else has tried a factory restore with this router. I have already flashed LEDE twice.

Thank you in advance. I had to install PuTTy just to get a command line interface, which I am not good at.

Three failed boots will automatically revert the router to factory firmware.


To get back to OEM you will have to ssh into device and:

scp image to /tmp
sysupgrade -F -n /tmp/imagename

Edit: my interpretation was that the OP was on LEDE and wanted off.

Edit2: not if LEDE is on both, again my interpretation of the OP

1 Like

SSH is not available on Linksys routers (as you pointed out in another WRT3200ACM thread).

The WRT3200ACM has two partitions, so the "three failed boots" method reverts to factory.

Either way, the "three failed boots" will get the router back to factory.

Rather than editing one post with replies, it is much easier to follow if you quote and reply directly to the response.

If that's the case, TFTP is also an option...


Thank you everyone for the suggestions. But nothing has worked so far. The "Three Failed Boots" and TFTP solutions require that there is still a Linksys Image file in one of the partitions.

Both partitions have been overwritten with LEDE, I suspect.

I am trying the SSH solution with PuTTy, but am having trouble with the correct syntax. The SSH appears to connect and the scp command gives a usage report when typed by itself.

My file is C:\Users\glen\Downloads\Linksys\WRT3200ACM\FW_WRT3200ACM_1.0.6.181063_prod.img

The PC is and the router is no password running LEDE pretty well, but it does not store settings through a power cycle. I am hardwired into a switch port off the Ethernet connection on my laptop.

You are going to have to provide relevant information; correct syntax ssh/scp/sysupgrade, what direction/tool are you using to scp...
As surprising as it might seem, tftp is somewhat limited without a TTL-serial, wtf is that about.

@jwoods, I purposely chose to answer as I did because, to me, that was just a bunch of white noise, having nothing to do with the OP.

For scp you'll need winscp, once you have it installed and open, find your linksys firmware in the left hand panel (which should be the computer you're on) and drag it to the tmp folder in the right hand panel (which should be your router). Then ssh in with putty, cd to /tmp and use anomeome's sysupgrade instructions to flash the firmware.

Thank you Mike! That worked! The Linksys image is finally restored!

Thank you very much.

This is covered in depth in the WRT AC Series Wiki under OpenWrt > OEM, as well as how to Serial Flash.

For users with a WRT AC Series router, the device wiki should be the first stop

1 Like