[Solved] How to exclusively allow sending email from an address which is under blocked zone?

If you recall, I had suggested that you start with the rule wide open to verify that the printer works as expected, and then tightening it down once you know it works. This is precisely why -- this would have saved time and effort.

Aynway, it is either using multiple ports (25 + something else), or it is not using port 25 at all. If multiple ports are being used, it could be hard coded DNS or something else like that.

You will probably have to use Wireshark or similar to really find out.

1 Like

When I said this, I was trying to do tell you that I have successful experience when WAN enabled. But anyway, I understand that verification is needed for any good doctor. Thanks a lot!

Yes, the printer has another DNS page, in which I have hard coded the DNS.
image

When I set the DHCP to Auto, or add a Traffic rule to allow the Printer to access WAN via the DNS port, the problem has been solved!

Thanks a lot for your sincere help and teaching!

And this makes sense -- the reason it failed was because it could not get DNS resolution, so it didn't know where to send the email.

As you have found, your solution is to either use the router as the DNS or to open port 53 from the printer to the internet. That is, of course, in addition to port 25.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

If you want to prohibit your printer from talking to the internet, you'll probably have to set up an internal mail server in your LAN.

As soon as you allow DNS and SMTP, there's quite a lot your printer could do with that - and there's no reasonable option to limit the mail addresses to mail to or which DNS records to request (there are even tcp over DNS tunnels…).

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.