[Solved] How to enable FPU emulation on OpenWrt trunk?

Hi all,
I have used for many time 17.01.4 compiled with FPU emulation on DIR-860L (MT7621) without problems,
today I tried to compile trunk branch, always with FPU emulation actived with make kernel_menuconfig, but seems that the FPU emulation is always disabled and I get "Illegal Instruction" with software like mldonkey.

LEDE 17.01.4
root@LEDE:/hdd# ls /sys/kernel/debug/mips/
fpuemustats unaligned_action unaligned_instructions
root@LEDE:/hdd#

Trunk
root@OpenWrt:~# ls /sys/kernel/debug/mips/
unaligned_action unaligned_instructions
root@OpenWrt:~#

Where is the problem?
Many thanks

EDIT: I have checked and recompiled several times, the problem is only with the trunk version.

Maybe this helps?

Thanks for your help @Borromini, no it didn't help me.
Seems a bug, comparing the different kernel configurations can help me?

Enable CONFIG_KERNEL_MIPS_FPU_EMULATOR in your build system .config

Thanks @nbd, I've already enabled it... I only have this problem with 4.9.x kernel.
With lede-17.01 FPU emulation is OK

I'm talking about top-level menuconfig, not make kernel_menuconfig. The master branch has an option for it there, 17.01 doesn't.

You have save me!
fpu2

Many thanks @nbd :smiley:

Since your problem seems to be solved: Can we mark this topic "Solved" and close it? All questions asked, nothing more to add?

Yes, thanks!

No :wink: