[Solved] How to correctly change router LAN's IP address?

I would like to know what the correct way of changing the router's LAN IP address. I would like to know because my attempts to do so this far have resulted in me losing web access to the router and I end up having to reset the router.

What I've tried so far is to go to then change the address in the "IPv4 address" text box then save and apply. After I, say, changed this address from to, the web interface is no longer available on either or, the DHCP server is still handing out IP addresses in the subnet, PCs connected to the LAN ports no longer have internet access and though I can SSH into the router, I have to connect to rather than


There is a emergency revert feature in version 18 that will go back if the web GUI cannot be reached.

I would advise to:

  • Login via SSH
  • Edit /etc/config/network directly
  • Run /etc/init.d/network restart
  • Done!

Thank you! That worked perfectly.

1 Like

On which device did that happen and what was your client system? I am still trying to replicate that behaviour

Here are my details. Good luck.

Client system: Windows 10 x64 1703
Web Browser: Firefox 62.0 x64
OpenWRT version: 18.06.1 r7258-5eb055306f
Router model: Xiaomi Mi WiFi Router 3G

fwiw, I've previously reported this behaviour with 18.06.0 on Home Hub 5A too when attempting to change LAN IP using LuCI.

I've witnessed it with chrome on Windows, Mint Linux. Also tried IE and Edge and turning off any popup blockers.

The AutoRollback popup message offering the option to accept the change doesn't appear after 30 seconds count down. I think it is because there is complete loss of access to the router. eg. cannot ping it at all on existing or new IP address. Power cycling the hub restores access.

It's not clear why I witness this problem frequently, but I think it may only happen immediately after flashing the router with 18.06 image even when you choose not to 'keep settings'. (I frequently flash one of my hubs between 17.01 and 18.06 to check things)

I have found if I factory reset the hub using Reset button on the rear, and try again, then I am able to change the LAN IP address using LuCI successfully.

Feel free to mark the appropriate post as the solution; and to edit the title - adding "[SOLVED]" to the beginning.


bug confirmed here as well, only solution at present is thru ssh




ID_LIKE="lede openwrt"

PRETTY_NAME="OpenWrt 18.06.1"













LEDE_RELEASE="OpenWrt 18.06.1 r7258-5eb055306f"

  • Please explain the bug you're experiencing?
  • Can you provide a link to this report, if any exist?

It not usually common to claim a known feature of software is a "bug." In fact, it's very confusing. So I'm not sure if you're referring to the rollback feature in OpenWrt 18. There is a known method to proceed.

"Bug" as in luci doesn't accept the changes when it can no longer access the original ip address for the gui, therefore causing the rollback. It shouldn't rollback but simply not respond to a new interface or write the new contents to /etc/config/network and try to resolve the url to the new gateway ip.

Yes, you described a known feature, designed to prevent locking yourself out of the router accidentally.

...So what happens when you hit APPLY CHANGES ANYWAY???

Also, why were you trying to @XJDHDR ?

Yes, you described a known feature, designed to prevent locking yourself out of the router accidentally. ...So what happens when you hit APPLY CHANGES ANYWAY???

It locks the user out
1.) doesn't respond to the original page e.g.
2.) doesn't respond to the newly set page e.g.

Also, why were you trying to @XJDHDR ?
Referring to his issue specifically

Yes, this is a known issue of trying to change the IP via GUI. Most people don't realize, they're now required to browse to the page at the new IP. This is something I rarely see in documents...perhaps it needs to be added.

Can you post the thread you're referencing, as that account only shows this thread. As you may notice, he marked it as solved.

my setup:

Arris NVG599 Passthrough Mode

Netgear R7000 (router, ethernet connections)

Netgear R7000 (Stock Dumb-AP)

Can you not see the entire thread? Just wondering because I can

Are you trolling?

I'll ask again...

Because, I get this:

  • Change IP to


  • I get warning
  • I hit "Apply unchecked"
  • WOW...once I get a new IP (you might have to do this manually, depends on your network card/wireless)


Notice new IP.

No, works in 18.06.1.


  • Also, I surmise you could also press "Dismiss", and they should then be saved, and upon rebooting, you have a new IP, too.

No I'm not trolling, inquire with @moeller0 about my validity. Last night is when I setup my network with the (2) R7000's. The GUI didn't and wouldn't respond to the changes. You guys really need to work on your people skills.

Not calling you a liar or anything....cool out...

But...consider making another post about your issue; as you see that feature works.

  • Maybe you didn't physically reset your Layer 2 by disconnecting/reconnect the cable...or enable and disable in network manager???
  • Also, did you remember to manually browse to the new web GUI page?
  • Did you make a network configuration where it's no longer possible to reach the web GUI?

So in addition to SSH:

  • Hit "Apply unchecked"
  • Just save and reboot, or /etc/init.d/network restart
  • Hit "Dismiss" and you should be able to save and reboot

Yes Sir I have followed the basic steps :wink: I loaded the firmware via serial cable/tftp, then factory reset. After not being able to connect via the changes I downloaded a fresh copy, loaded via serial/tftp again and still the same results. The only solution was manual configs.

But...consider making another post about your issue; as you see that feature works.

This topic will close 10 days after the last reply.

The topic wasn't closed yet

1 Like