[Solved] How to compile 15.05 release (“Build dependency: Please install Git (git-core) >= 1.6.5” message


https://wiki.openwrt.org/doc/devel/patches

It is an openwrt bug in include/prereq-build.mk:
https://github.com/openwrt/openwrt/blob/chaos_calmer/include/prereq-build.mk#L148

But the link do not exist. I have git-version-check-fix.patch, but do not know, how to use it.

Which git version do you have installed in your buildhost?
Just install a current git version to your PC.

git is not part of Openwrt sources, it is an external prerequisite. Mentioned on the list here: https://wiki.openwrt.org/doc/howto/buildroot.exigence

And no idea what is "spack", and what is its relevance to Openwrt/LEDE...

Ps. the correct link to old chaos calmer sources would be
https://github.com/openwrt/chaos_calmer/blob/chaos_calmer/include/prereq-build.mk#L148

There's a patch for the issue...

2 Likes
~/Oolite8/openwrt15$ git --version
git version 2.16.1

Is it a current git version?

1 Like

~/Oolite8/openwrt15$ git apply git-version-check-fix.patch solved the problem. Link:

https://gitlab.labs.nic.cz/turris/openwrt/issues/56
https://gitlab.labs.nic.cz/turris/openwrt/uploads/0673001b14ab1d1769604ff0ce7d8781/git-version-check-fix.patch

Thank you all for suggestions. Issue resolved.
I had enabled Build OpenWrt SDK option under make menuconfig.
After disabling the above option now its compiling.
Thanks for your time
Manju

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.