( Solved )How to activate POE passthrough on CPE210 with LEDE fm

Dear All
Does any on know how to activate POE passthrough on CPE210 V1 with LEDE fm
Thanks in advance

Regards

PoE Passthrough

GPIO 20 high for PoE Passthrough:

echo 20 > /sys/class/gpio/export
echo out > /sys/class/gpio/gpio20/direction
echo 1 > /sys/class/gpio/gpio20/value
To make this persistent accross reboots, add the above lines to /etc/rc.local before exit 0

Its doesn't works..
only on for temporary..and then turn off again

It works for sure,I am using it on plenty of CPE 210-s to power another CPE210 on ETH1 port.
What do you mean with temporary?

When i insert all the persistance on the startup before exit 0 and reboot the device
Poe Turn On another device for only 1 second and then turn off it again..
what i missing ?

Please help me

Ok,can you try executing the commands over SSH and then see if POE will be passed?
Also,can you show me the contents of your rc.local file?

if using SSH comand yes ..its turn on
but how to save this comand..?
my condition is if i reboot the CPE, Other device also OFF again.

BTW ,when i open rc.local file ,there is error message "permission denied"

root@LEDE:~# cat /etc/rc.local
echo 20 > /sys/class/gpio/export
echo out > /sys/class/gpio/gpio20/direction
echo 1 > /sys/class/gpio/gpio20/value

I can open the file..and above is the content of that file

Do you have exit 0 under that code?

that manually method isnt needed anymore
(it would work when doing it as an cronjob)

but now there is an UCI config for that.

please have a look at /etc/config/system
so find the PoE section and enable it.

Yep sure...but i forget to copy it

Thank you frei
you mean i should open content in this file /etc/config/system with ssh terminal..?
and make some modification on it..?

I did not know that.
That is awesome,that way I can make preconfigured images.

Any examples?

root@LEDE:~# cat /etc/config/system

config system
option hostname 'LEDE'
option timezone 'UTC'
option ttylogin '0'
option log_size '64'
option urandom_seed '0'

config timeserver 'ntp'
option enabled '1'
option enable_server '0'
list server '0.lede.pool.ntp.org'
list server '1.lede.pool.ntp.org'
list server '2.lede.pool.ntp.org'
list server '3.lede.pool.ntp.org'

config rssid 'rssid_wlan0'
option dev 'wlan0'
option refresh '200000'
option threshold '1'

config gpio_switch 'poe_passthrough'
option name 'PoE Passthrough'
option gpio_pin '20'
option value '0' ===> please change to '1'

config led 'led_lan0'
option name 'LAN0'
option sysfs 'tp-link:green:lan0'
option trigger 'switch0'
option port_mask '0x20'

config led 'led_lan1'
option name 'LAN1'
option sysfs 'tp-link:green:lan1'
option trigger 'switch0'
option port_mask '0x10'

config led 'led_rssilow'
option name 'RSSILOW'
option sysfs 'tp-link:green:link1'
option trigger 'rssi'
option iface 'rssid_wlan0'
option minq '1'
option maxq '100'
option offset '0'
option factor '13'

config led 'led_rssimediumlow'
option name 'RSSIMEDIUMLOW'
option sysfs 'tp-link:green:link2'
option trigger 'rssi'
option iface 'rssid_wlan0'
option minq '26'
option maxq '100'
option offset '-25'
option factor '13'

config led 'led_rssimediumhigh'
option name 'RSSIMEDIUMHIGH'
option sysfs 'tp-link:green:link3'
option trigger 'rssi'
option iface 'rssid_wlan0'
option minq '51'
option maxq '100'
option offset '-50'
option factor '13'

config led 'led_rssihigh'
option name 'RSSIHIGH'
option sysfs 'tp-link:green:link4'
option trigger 'rssi'
option iface 'rssid_wlan0'
option minq '76'
option maxq '100'
option offset '-75'
option factor '13'

Problem Solved
Thank you all
by editing file /etc/config/system by using Putty
and change below configuration

config gpio_switch 'poe_passthrough'
option name 'PoE Passthrough'
option gpio_pin '20'
option value '0' ===> please change to '1'

my problem was solved
thank you

1 Like