[Solved] Hi! im new noovi sorry :( but have a stupid problem

I have an old wr941nd v5 that I wanted to dust off and use as a bridge, before I try it to doit it with ddwrt but it cannot be installed on this router, so I looked for another great one that I had never used before like openwrt.

I followed this youtube https://www.youtube.com/watch?v=qt-ucxqn4vg with the firmware openwrt-15.05.1-wr941nd-v5.1-TE7WR941NXV5-factory.bin and I was happy because I would finally use this firmware but I was greedy to have the latest version and update to this openwrt firmware-18.06.8-ar71xx-tiny-tl-wr941nd-v5-squashfs-factory.bin

CRASH my router turns on with this error

/usr/lib/lua/luci/dispatcher.lua:234:/etc/config/luci seems to be corrupt, unable to find section 'main'
traceback stack:
[C]: in function 'assert'
/usr/lib/lua/luci/dispatcher.lua:234: in function 'dispatch'
/usr/lib/lua/luci/dispatcher.lua:127: in function </usr/lib/lua/luci/dispatcher.lua:126>

Here in the forum i found in this post they teach how to "fix it" but I could only copy and paste the 2 1st commands LUCI WebGui crash after updating to Ver.18.6.8 on TP-LINK TL-WA801N v2

the thing that say is:
"adding to /etc/config/rpcd
config rpcd
option socket /var/run/ubus.sock
option timeout 30"

I don't know how to do it or what to do... the I only i actually have is the ssh window open with the first 2 lines of commands entered but I don't know what else to do...

can you help me with this nonsense and I apologize for 1000 times if this is something very simple and I am drowning in a glass of water
Thank you pleease

@royitoroy, welcome to the community!

Try 18.06.7.

thanks friend... but i dont know how to fix this error at first... can you helme? how can i do this?
"adding to /etc/config/rpcd
config rpcd
option socket /var/run/ubus.sock
option timeout 30"

1 Like

You just need to read further on the thread you linked in your first posting.

If installing nano or using vi is too complicated, maybe editing the file with winscp is easier for you: https://openwrt.org/docs/guide-quick-start/sshadministration#using_winscp

1 Like

yeah i really dont know how tyo do that, run nano or vi... sorry.., thats i am looking for some tutorial over youtbe... sorry for my ignorance in this... ive never use before the shell...

any help in that case would be great for me... :wink: i am goin to look for that winscp

Maybe this will help:

In this case, your command is: nano /etc/config/rpcd

1 Like

thanks im also find some guy who teaches ugrade a firmware from the ssh O.O... im waching it too https://youtu.be/FHS5JAR_TTs to can change to another previous firmware...

i whish some of this could help me to back to life my router

no i can not because dont want to install it because i get this

root@OpenWrt:~# sudo apt-get install nano
-ash: sudo: not found

i guess it beacuse i dont have internet in the router so canot download the packages...

:frowning:

It's because you are not reading the postings properly.

From the posting above:

opkg update
opkg install nano

And there is also a link to a youtube video... just in case you missed that.

2 Likes

I showed you:

opkg update
opkg install nano

:confused: You are gonna fix this before attempting again, correct?

1 Like

sudo isn't part of OpenWrt since by default you log in as root it is not necessary.

Installing nano (or almost anything) is not recommended on a 4 MB flash device due to lack of space. Use vi which is built in, or scp the file to your PC, edit it, and scp back.

First thing to try after upgrading and LuCI throws errors or does not load is to clear the browser cache.

sorry :frowning: in the video it teach it with sudo...

but its DONE :slight_smile: thanks bro

yeah its fix it riogth now! just di a hard reset 30/30/30 and disconected from 2 min and when i replug it the internet was ulink and the interface gui was ok too :slight_smile:

aaa ok mk245 thanks i will try later to learn something from vi... but i did a hard reset on 30/30/30 and unplugged it for 10 or more minutes and that was it... now i dont know if i have to stay at that firmware version or make a change to a better one ugraded or downgrade for this router for a more stable openwrt firmware version...

@lleachii It just recommend 18.06.7

What do you think it could help me or because I want it to connect it with the archer c7 trouhgt cable lan as a bridge/WDS and the wr160n with ddwrt that I have

No such thing.

I'm not sure what you mean. If your web GUI problem is fix. You're OK.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

yes, thanks for the notice :wink:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.