[Solved] Help with bricked Teltonika RUT955

Before anyone mentions that Teltonika have their own support forum for their routers, I have already asked there about numerous problems without getting anything resolved, that's why I'm asking here, hoping that someone might be able to breathe life into my brick.

Because of problems with the firmware which was installed I upgraded it to the most recent available on Teltonika's website:-


I only managed to upgrade by downloading it directly from their server which was an upgrade option. If I tried to upload from a local copy of the fimware I would get invariably get 'Incorrect checksum', This has happened with every version of the firmware apart from R_00.06.08.5.

In my attempt to get the system back up and running, I did a factory reset, which seemed to take a long time, but eventually I was able to ping although unable to ssh in.

I tried logging in via the browser but got response initially, until I read the bottom of:-

where is showed:-

  • Bootloader upgrade URL:
  • Firmware upgrade URL:

I was unsure about the bootloader upgrade and didn't even know what was available, so tried all the files I could find, but all except R_00.06.08.5 errored with Incorrect checksum.. This particular one however was applied successfully. Unfortunately the system never returned. After power cycling the unit, I couldn't even ping it.

Could anyone here please suggest what I could do?

I'm not getting any help from the Teltonika forum.

Someone suggesting upgrading the bootloader but have been unable to find where to download one from. Teltonika website doesn't easily tell you where they are.

there's a serial port, you probably want to connect to it, check if there's any sign of life ...

You might try to install official openwrt.

1 Like

I would try to install it if I could find it...

I did try connecting a serial port and tried to access the device using minicom, but didn't really know what parameters to use.

there should still be garbage. even if the parameters are wrong.
if there's no output, it's either dead, or you need to swap the RX and TX cables.

i assume GND was connected too?

I used an RS232 to USB adapter so I assume it did.

Is it possible that the serial port is disabled?

After a factory reset I can ping (but no ssh) and there are two URLs available, and so the device isn't entirely bricked. I haven't found a bootloader image to upload yet, although one of the for firmware images were accepted to upgrade the firmware. The three newer ones were rejected because of 'incorrect checksum' although I have checked my downloaded files' checksums against provided pn Teltonika's website and they are the same.
The only firmware image which is accepted makes the unit completely inaccessible - not even ping works, after a reboot.

I managed to unbrick this device after updating the bootloader which I finally found after reading this post:-


After getting the device unbricked, I've inserted a Virgin SIM and it looks to have connected with the Internet. At least I see a strange entry when I run ifconfig:-

qmimux0 inet addr:

But I can't ping so it looks like I need to configure something but not sure what.

Can anyone help me out here? Do I need to manually edit /etc/config/network or do I need to enable something via the GUI?

Have you seen https://openwrt.org/docs/guide-user/network/wan/wwan/ltedongle

1 Like

Thanks, but it did my head in trying to make any sense of that link.

Fortunately I applied an upgrade to the next available firmware, and magically, voila, there was!!!! both via ssh and directly from my attached PC.

It's four months since I got this thing, and finally I have it working!


If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like